summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-17 06:07:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-17 06:07:05 +0200
commit187b82af8a6029766ad9358458e231e9a462b89a (patch)
treeb4d770d076986801e6f95ed972aff7f99f0e565c /dev-python/pytools
parentdev-python/pytest-subtests: Bump to 0.13.1 (diff)
downloadgentoo-187b82af8a6029766ad9358458e231e9a462b89a.tar.gz
gentoo-187b82af8a6029766ad9358458e231e9a462b89a.tar.bz2
gentoo-187b82af8a6029766ad9358458e231e9a462b89a.zip
dev-python/pytools: Bump to 2024.1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2024.1.9.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 5af06df5a26f..8c394c7f9ffd 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1,2 +1,3 @@
DIST pytools-2024.1.6.tar.gz 81344 BLAKE2B ff68e2606170bf54e3f609ee7f4cfe58e063f43dcfb2706d5ed7659ea2fde863e6315d0d81dff2e62a3378f195413561a927b0c1e7bedc06388cf4893c07b873 SHA512 a9e934f1cbaf0ace32420f9b74224a06ce8421ee291b837292133969c6788c4cc8bea01446cd4d1505aca9fa81e8ae0d3eacf60d3285186e66d67d5abe10ce3e
DIST pytools-2024.1.8.tar.gz 82220 BLAKE2B bc1dd2eb80be38f6ee450f2d0a780b4815b3a3349bc99ca8521a891bccbc0c4e532881db749def53e26e088238f852ca9174e0fc2a7a7a43a064c1caadec2772 SHA512 d49a6c2cd73915dbc9446f4ed2a05ac30c3235b8fd57fc26814c42cb31ab43c54ae3b06ad69354c7932f266e0f2e0fcde4b9ff91426f8744f924e3d6837f0060
+DIST pytools-2024.1.9.tar.gz 80992 BLAKE2B 0c097690eaba7e40be3bc6ec5a0a3a3fd19cd793cd637a7c4ecf89adbd0a64ee63340f7d631c3b23a35e9230de37b239306da35fd7a8d9d9a50a7ea39198f977 SHA512 224bc9e98f6e2fdac1433f1d486946ce17d7b48271b78110066ebbb59384e0e8f3087ad82899fc6fdae4494198872acda384426c49a01b3d3c879eaf9b618323
diff --git a/dev-python/pytools/pytools-2024.1.9.ebuild b/dev-python/pytools/pytools-2024.1.9.ebuild
new file mode 100644
index 000000000000..0f076af0c8bc
--- /dev/null
+++ b/dev-python/pytools/pytools-2024.1.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/siphash24-1.6[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+ ' 3.{10..12})
+"
+
+distutils_enable_tests pytest