summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-02 09:00:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-02 11:59:17 +0100
commit7ebc8f59109cf52e0eb1f77e8ee560b6073fd5b4 (patch)
treec2787f9a9e2f5117b23265d1a796d03f17fc07e2 /dev-python/python-utils
parentdev-python/sphinx-autodoc-typehints: Bump to 1.13.0 (diff)
downloadgentoo-7ebc8f59109cf52e0eb1f77e8ee560b6073fd5b4.tar.gz
gentoo-7ebc8f59109cf52e0eb1f77e8ee560b6073fd5b4.tar.bz2
gentoo-7ebc8f59109cf52e0eb1f77e8ee560b6073fd5b4.zip
dev-python/python-utils: Bump to 2.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-2.7.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index d412cc4e6bc7..60c609ddd0e5 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -2,3 +2,4 @@ DIST python-utils-2.5.6.tar.gz 14057 BLAKE2B 2f66ab26cd6cda25f73c9f40081048404cd
DIST python-utils-2.6.0.tar.gz 14885 BLAKE2B 089d7a57a8469968bed147a01907f35d1430349130e0f7152bbd38dd65053cf3d6424942eee8cc9006baaec5f13bffcbef81bd8723cad7ee03b1358a5c2d3d27 SHA512 a582558e38342f54f7c1eda1f9038728dd5904729aaec4e5719e56bb447bc6fcb93bf5ea3af134ce245eda059b9be81d15b268165cbc10799ba112fc157f939b
DIST python-utils-2.6.3.tar.gz 14914 BLAKE2B 6df19348feba000dccc516704db38af299613c70505cd7fa16a2e37c4a46b1cff7ee9bf164be13da33a3b4eb6b9577b76202bfbffdaed47b1b7b60e948d349ac SHA512 3c5834976408eae6b37aa07581960ee5511765f9ea1e6347523465a93ca801bc2d71f785a73a2050706dad2c09ffcfb5227715a9b4d0700904d31eb1295b30b6
DIST python-utils-2.7.0.tar.gz 27743 BLAKE2B 5cd0671ad1e003932aed0bf0b69326d907013d3f739e833f218600ee056d76bc87dd2a424f5459654de30dacc3378c14f10af1664344ac66813410d261718c61 SHA512 3401c9ad2e4933d0d40d4bc90f1dbe212e672289e7239a4a46d79a04e80f85bb0def67324f0184ca397ec3708cb935839ffe922a202de9c911198ea86d88e2c5
+DIST python-utils-2.7.1.tar.gz 28997 BLAKE2B 3da11dcb297cace3c2c48ae91e6011be2f484a83f264be375437775eb99d9bafe703626ab0d2217da79ec096f90648d387ec7b41611e915ef33fce152553a18c SHA512 9f74a33089886dcd28dfd45602c53a7c6cfc90b151a053dd7e49a5fd502479e889d08bd8b10fdd2ec3bc26e334ae66238740ff59291f4ac95fb486b64f925d4a
diff --git a/dev-python/python-utils/python-utils-2.7.1.ebuild b/dev-python/python-utils/python-utils-2.7.1.ebuild
new file mode 100644
index 000000000000..325baeedb039
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}