summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-21 17:38:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-21 18:59:41 +0200
commitedf9c8d7b985806278df484aa146fe05f781feb6 (patch)
treeea1c08db48f0668ca6ea15d805ee4aeff3c4e90a /dev-python/python-snappy
parentdev-python/sphinx-autoapi: Bump to 3.1.2 (diff)
downloadgentoo-edf9c8d7b985806278df484aa146fe05f781feb6.tar.gz
gentoo-edf9c8d7b985806278df484aa146fe05f781feb6.tar.bz2
gentoo-edf9c8d7b985806278df484aa146fe05f781feb6.zip
dev-python/python-snappy: Bump to 0.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-snappy')
-rw-r--r--dev-python/python-snappy/Manifest1
-rw-r--r--dev-python/python-snappy/python-snappy-0.7.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-snappy/Manifest b/dev-python/python-snappy/Manifest
index bfc66478f799..b88f638bdcd8 100644
--- a/dev-python/python-snappy/Manifest
+++ b/dev-python/python-snappy/Manifest
@@ -1,2 +1,3 @@
DIST python-snappy-0.6.1.tar.gz 24110 BLAKE2B 66ba24aa1768084c87188dde6eb6c98daf90da39e49902bbc283226aaf28b8d267bbc69f3cb9f30d9aaf64b3e25cc0fae47113bcc65f18dbec2128294c0dbe4b SHA512 43301f568633068bbdcb3dc318f37efcabbb5bd3f61a06b3a3a476006c3cbc1dfddea4ac2de0876bb127b354aa81ccc55dc44631dc8fba06036a0b6c7dfbdb9b
DIST python-snappy-0.7.1.tar.gz 8832 BLAKE2B 5968b146fa637b4c6785a74b17cca1539599235c44a45350e8c5ee9c1fed27eeea1818428045acb2ce7492aa22363407f79f8ccb66d04e5f6eab36fbbdfff5eb SHA512 f820131f817cb4fc963b6baa8e3854970d3e9947154c4810e0f8f268363ada6b380ca725be463a5967ef00447fd8e30a344c91e4d4dfd75ecdc8f17afda41c75
+DIST python_snappy-0.7.2.tar.gz 9108 BLAKE2B a0f23b286f97de2d61afc51dcba188d77d0c0099b7cba26c7a0e2bc4da41045fc6a4a95d3adf3ef80d16300a7d35a66955552cf5693c0a0a38b73478b864d266 SHA512 c585e9e953c2bf2cb7d3f24ae9745d267b334d681ca44b7d842de2405df19b24af0f6915f0274de2a86e74fdcfef3715e5c27765243d84459216476c31aaa437
diff --git a/dev-python/python-snappy/python-snappy-0.7.2.ebuild b/dev-python/python-snappy/python-snappy-0.7.2.ebuild
new file mode 100644
index 000000000000..1883fcc0bc23
--- /dev/null
+++ b/dev-python/python-snappy/python-snappy-0.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library for the snappy compression library from Google"
+HOMEPAGE="
+ https://github.com/intake/python-snappy/
+ https://pypi.org/project/python-snappy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cramjam-2.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest