summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-24 05:06:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-24 05:06:42 +0200
commit52e332db5f370d5182af7317446910ba05df0941 (patch)
treeaef2400080bb4cae0c7737b516ab23cd65780f7c /dev-python/pytest-xprocess
parentdev-python/psycopg: Bump to 3.1.11 (diff)
downloadgentoo-52e332db5f370d5182af7317446910ba05df0941.tar.gz
gentoo-52e332db5f370d5182af7317446910ba05df0941.tar.bz2
gentoo-52e332db5f370d5182af7317446910ba05df0941.zip
dev-python/pytest-xprocess: Bump to 0.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index d80b8e72a08a..f9c2c41abdd7 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.22.2.tar.gz 31346 BLAKE2B 07b9fdfea2ecd3d3aaf4115c2f7ecd41c864b4490694cedc54460d0f16397ebdda0ac88fd9bd1613dcaec1cb9c36571b8ab2febc8d151f8f6c4e19fe3abd0821 SHA512 2051be110dfda8063c31bb9555bff569f5d7a1332a62f8ce57fd799dfc7d8551ba1227df12f44fccc1ec62d9fcc0face104a77c9c5cc1abb583b74cd1d8a9ff7
+DIST pytest-xprocess-0.23.0.tar.gz 31350 BLAKE2B 71492aa1bbc438221c6ac2825bf2bd678a75c12e8b5a8654d333c1ba2ad5c66b21f85e572998f0e5f1835097483a4895942d664ef7d8f078cad7923a9ee2e962 SHA512 97aa2a8ba0bcca62d53c0a0523696f6ae5fec5eae29e3e2cfe1a3ec8f14622c2c31f0802b2e65b55aa16778dd6ea82951e15af768c9d84cfd13aa2d427f94c9e
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild
new file mode 100644
index 000000000000..adb5647ee026
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest