summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-27 11:56:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-27 11:56:39 +0200
commit3636323c4b4aae40c45395c8038b5967ac78f7da (patch)
treec56459b5d6977d23bf85ee0c8cd470408ee581a0 /dev-python/pytest-twisted
parentdev-python/itunespy: Remove old (diff)
downloadgentoo-3636323c4b4aae40c45395c8038b5967ac78f7da.tar.gz
gentoo-3636323c4b4aae40c45395c8038b5967ac78f7da.tar.bz2
gentoo-3636323c4b4aae40c45395c8038b5967ac78f7da.zip
dev-python/pytest-twisted: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-twisted')
-rw-r--r--dev-python/pytest-twisted/Manifest1
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pytest-twisted/Manifest b/dev-python/pytest-twisted/Manifest
index 3e6cac8d0ff5..4dd9a8e86275 100644
--- a/dev-python/pytest-twisted/Manifest
+++ b/dev-python/pytest-twisted/Manifest
@@ -1,2 +1 @@
-DIST pytest-twisted-1.14.1.gh.tar.gz 17114 BLAKE2B 36b851b734acc03919dc03842d942d205468375d9318d4ce4f880532fca29d31354125fd2ab8149a50bcf29e46ec812898b7167e34c0fa1276dcd5c2aa36ccd1 SHA512 d5b6d629ed3cf7ae1537e76494fa7eb4bbb9767cbc50d97a5657c668b381f39236acc6224b3754d62e2cccd4dff7e6161265ddc6a939f0488cef53eeade0eae9
DIST pytest-twisted-1.14.2.gh.tar.gz 17120 BLAKE2B d12c00c5a01c8219626f5a85d5cee4b2f0fc27d4dbea5c38e4fa7e374d1ca04098b1e8bc453ff1391415b2999eb1bb1f0472cef85bb4b4b2e50a1d2632cb6177 SHA512 51c915dfba829442b68c981f80d42cc22ece12a81388f239211ca73bb76dbfadeec76722df44b2e6b6473a4a3886031846a47b855ef217ed240a7c28d20f6160
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
deleted file mode 100644
index f90693d8ef2f..000000000000
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="A pytest plugin for testing Twisted framework consumers"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-twisted/
- https://pypi.org/project/pytest-twisted/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-twisted/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # If we let pytest-twisted autoload everywhere, it breaks tests in
- # packages that don't expect it. Apply a similar hack as for bug
- # #661218.
- sed -e 's/"pytest11": \[[^]]*\]//' -i setup.py || die
-
- # https://github.com/pytest-dev/pytest/issues/9280
- sed -e '/^pytest_plugins =/d' -i testing/conftest.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_twisted
-
- local EPYTEST_DESELECT=(
- # regression with pytest-8.2
- # https://github.com/pytest-dev/pytest-twisted/issues/176
- testing/test_basic.py::test_async_fixture_module_scope
- )
-
- epytest -p pytester
-}