summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-23 21:48:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-23 22:06:47 +0200
commit7cb566148972f25b4c1f8ef9b3fbdcf9a71d501c (patch)
tree5baa8f571bb03a18d477842de6381041f91b0c14 /dev-python/pytest-reserial
parentdev-python/starlette: Bump to 0.38.1 (diff)
downloadgentoo-7cb566148972f25b4c1f8ef9b3fbdcf9a71d501c.tar.gz
gentoo-7cb566148972f25b4c1f8ef9b3fbdcf9a71d501c.tar.bz2
gentoo-7cb566148972f25b4c1f8ef9b3fbdcf9a71d501c.zip
dev-python/pytest-reserial: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-reserial')
-rw-r--r--dev-python/pytest-reserial/Manifest1
-rw-r--r--dev-python/pytest-reserial/pytest-reserial-0.4.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-reserial/Manifest b/dev-python/pytest-reserial/Manifest
index 0d0a4af0c659..6e222b761d17 100644
--- a/dev-python/pytest-reserial/Manifest
+++ b/dev-python/pytest-reserial/Manifest
@@ -1 +1,2 @@
DIST pytest_reserial-0.4.1.tar.gz 11687 BLAKE2B 68c54b8e89c25d41fcb99f715a6008f71f55ad9e3101b37a90bb3b944fac473dd66392d08bcbe464af942fae58d9406492a65a3d61b547bef33d446b46d69f6a SHA512 1ac92258b3fdfeb9aca95b105c7a8ea21891f2609c591e7aa07ed8cc3d9b17f48eb7ec7d3d53524b564d5572ca679d897b8b06107fc4c370f3ed3cd2125cdfdf
+DIST pytest_reserial-0.4.2.tar.gz 12374 BLAKE2B 4f0d89bef2f4f99f2a9d9ef1ac5c46e31817ed4c91b78bd41f2670a89dd87dd642a1c80f0574957c24467cb77cebb9f0de27e540b47e0f70933cd6cf4a933ac7 SHA512 e3b9a82feee58c6808bb0491bf6c92f6ee0e1f83b3fafb676a4eac4ed03c90e29ead8d93ed275a83a7f2de3148aa55ba27f6dc6266c2e308e7085794d88a0ffa
diff --git a/dev-python/pytest-reserial/pytest-reserial-0.4.2.ebuild b/dev-python/pytest-reserial/pytest-reserial-0.4.2.ebuild
new file mode 100644
index 000000000000..d7bd5483c32e
--- /dev/null
+++ b/dev-python/pytest-reserial/pytest-reserial-0.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for recording and replaying serial port traffic during tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-reserial/
+ https://github.com/bessman/pytest-reserial/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest