summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-28 23:14:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 00:01:29 +0100
commit9103a16e1da48dae25563e59a213fcf0f97706b1 (patch)
tree80e5953abc7d8ffae8b9abc7aea6018d414ada1d /dev-python/pytest-mock
parentdev-python/pytest-mock: Add test dep on pytest-asyncio (diff)
downloadgentoo-9103a16e1da48dae25563e59a213fcf0f97706b1.tar.gz
gentoo-9103a16e1da48dae25563e59a213fcf0f97706b1.tar.bz2
gentoo-9103a16e1da48dae25563e59a213fcf0f97706b1.zip
dev-python/pytest-mock: Disable plugin autoloading during tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.7.0.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
index 741a457784be..3e6c060c2c67 100644
--- a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
@@ -25,12 +25,10 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- sed -e 's/runpytest_subprocess(/&"-p","no:xprocess",/' -i tests/test_pytest_mock.py || die
- distutils-r1_src_prepare
-}
-
python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
+
if has_version dev-python/mock; then
local EPYTEST_DESELECT=(
tests/test_pytest_mock.py::test_standalone_mock