summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-02 14:26:58 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-02 14:27:23 -0500
commitb49e07aa377bf41adee64cf3a0c59d57aba929ec (patch)
tree343b413e0fff9f5b0be1b70d32bb9a94152cd54a /dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
parentx11-base/xcb-proto: python3_8 (diff)
downloadgentoo-b49e07aa377bf41adee64cf3a0c59d57aba929ec.tar.gz
gentoo-b49e07aa377bf41adee64cf3a0c59d57aba929ec.tar.bz2
gentoo-b49e07aa377bf41adee64cf3a0c59d57aba929ec.zip
dev-python/pytest-mock: exclude two additional introspection tests
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-1.11.2.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.11.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild b/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
index 9abdcee85b10..93d187c92726 100644
--- a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
inherit distutils-r1
@@ -29,6 +30,8 @@ src_prepare() {
sed -e 's|^\( def \)\(test_failure_message_with_no_name(\)|\1_\2|' \
-e 's|^\( def \)\(test_failure_message_with_name(\)|\1_\2|' \
-e 's|^\(def \)\(test_detailed_introspection(\)|\1_\2|' \
+ -e 's|^\(def \)\(test_assert_called_args_with_introspection(\)|\1_\2|' \
+ -e 's|^\(def \)\(test_assert_called_kwargs_with_introspection(\)|\1_\2|' \
-i tests/test_pytest_mock.py || die
distutils-r1_src_prepare
}