summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 05:15:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 05:34:01 +0100
commitc06d88ba711699e7c9e57d65e46a7a39fd791e8f (patch)
tree723ab74931c9791b87327e4b7421a8cc2b733de6 /dev-python/pytest-httpx
parentdev-python/zeroconf: Bump to 0.126.0 (diff)
downloadgentoo-c06d88ba711699e7c9e57d65e46a7a39fd791e8f.tar.gz
gentoo-c06d88ba711699e7c9e57d65e46a7a39fd791e8f.tar.bz2
gentoo-c06d88ba711699e7c9e57d65e46a7a39fd791e8f.zip
dev-python/pytest-httpx: Bump to 0.27.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 323df10db75a..0cc85135bc06 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest_httpx-0.26.0.tar.gz 33490 BLAKE2B 27c267374a575aff2ecbaec4855b733318568d73368a103f93606cc8833be4d4e664418e2f4b67df2d39a8830dd32d75d3a00656e58824b6beb18c4cc0bf3a14 SHA512 b671984714e8958361a773ef5e3f7430736b01556c6af58aac4ca740a679b5c2e316e2d041e1594cc16e7e13cee9692f57dcbbf374ca15924685250f73cc7853
+DIST pytest_httpx-0.27.0.tar.gz 33905 BLAKE2B 352812df060f878044a628dee62ab36f15d17080afc0367b6331c2e5e13600eefff7a3668f4a9364d437394ad8f8354f41619ec4f6b8bc5ac14b1cd652357802 SHA512 e2834313f507d02b9df96a47f8be6f46b451972e88ed9c9bfcb8bdb92545cc44064b11a1160a5d9d900381181918611d5d5a9efaf60f4e491f33182e9bd884dd
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild
new file mode 100644
index 000000000000..1926979c400c
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.25*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest