summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-12 07:29:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-12 07:50:32 +0200
commit684308de31e33e292a0d5aa126b3abd77bab8a45 (patch)
treef247d7226586eeb8f58f80f6eabc27a975819e37 /dev-python/pytest-httpx
parentdev-python/httpx: Bump to 0.25.0 (diff)
downloadgentoo-684308de31e33e292a0d5aa126b3abd77bab8a45.tar.gz
gentoo-684308de31e33e292a0d5aa126b3abd77bab8a45.tar.bz2
gentoo-684308de31e33e292a0d5aa126b3abd77bab8a45.zip
dev-python/pytest-httpx: Bump to 0.25.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 00a826c50962..9aaa64c3208c 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,2 +1,3 @@
DIST pytest_httpx-0.23.1.tar.gz 29462 BLAKE2B aaccef0152a4b7a6340ef322135dcea366df04f349e5d0b4ee9f02a9995485306da4c7854ef4235543b0dcb0228e2f5957790b2b58a0f41bb739849bfdf26cbc SHA512 4490c716c341d782ebf02c29475b7618c0717bbaa736b0a0eefee8a7c8498d3474dd28d487469fe5806ba0018a07b538d2f583406f561c451de6f8a688d57901
DIST pytest_httpx-0.24.0.tar.gz 31665 BLAKE2B 2b9ec1c97635179b10052b32a5e1245ec44882f485e427cad7e278913c62b300f0a2e6637254469be15c68905e8b3fe2a34923e583f780b08e14433d625382f2 SHA512 b84b7fa80bcc80c8e1ef7324bd3e559d020b993bafa8835ea40bd33d6fc97208e391d86807ee2c7959eda01f615e1001876f346e67fb9dc645ad00a1feea9e64
+DIST pytest_httpx-0.25.0.tar.gz 31681 BLAKE2B 6ebeda25278ef2f80705d8cafdf3acb745feb4594aa966efc2c4bd258ccee312a3a11a89e0dff2ae789bc1dbc5dce3b8ccd74b23144ba7fa2ff9fef8ac13557f SHA512 a2513b5d75f281fae12e8e06151eaa52e35defa67aeca1f5ea146ecf3735897c0d440d11af8dbfb31a2be8ff9ea5d86962060c78b8d3ea1d83c0c870611a2a5f
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild
new file mode 100644
index 000000000000..1926979c400c
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.25*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest