summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-01-22 12:55:04 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-01-22 13:33:29 +0100
commit15a1841e639dbfc94909b5bf4fbe881baaf440e2 (patch)
tree4f336c24d555b295ba08e1955c83e22c37654ca5 /dev-python/pysrt/pysrt-1.1.2.ebuild
parentnet-proxy/squidguard: fix QA issue with automake call in src_prepare (diff)
downloadgentoo-15a1841e639dbfc94909b5bf4fbe881baaf440e2.tar.gz
gentoo-15a1841e639dbfc94909b5bf4fbe881baaf440e2.tar.bz2
gentoo-15a1841e639dbfc94909b5bf4fbe881baaf440e2.zip
dev-python/pysrt: bump to 1.1.2, add Python 3.8 support
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pysrt/pysrt-1.1.2.ebuild')
-rw-r--r--dev-python/pysrt/pysrt-1.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.2.ebuild b/dev-python/pysrt/pysrt-1.1.2.ebuild
new file mode 100644
index 000000000000..766998ae2d3e
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests failed under ${EPYTHON}"
+}