summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyqwt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyqwt')
-rw-r--r--dev-python/pyqwt/Manifest1
-rw-r--r--dev-python/pyqwt/metadata.xml15
-rw-r--r--dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild89
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/pyqwt/Manifest b/dev-python/pyqwt/Manifest
new file mode 100644
index 000000000000..ebf99224a9f2
--- /dev/null
+++ b/dev-python/pyqwt/Manifest
@@ -0,0 +1 @@
+DIST PyQwt-5.2.0.tar.gz 2670893 SHA256 98a8c7e0c76d07701c11dffb77793b05f071b664a8b520d6e97054a98179e70b SHA512 8c409ee228d91d625bf9bd8a5704c3d41f70613b420bc8f1527312dd1ebb686b8482bd68c4b3d1a72edd80673533a4f5a39378221967bea70f389c9dde14f265 WHIRLPOOL ab5e8d1b094552df592062ad41d786e58621465d318eaa2e199cdf45163e39be24f8c268aec33b428b4daa92c4c85342925df109792475507425f90c76e86c70
diff --git a/dev-python/pyqwt/metadata.xml b/dev-python/pyqwt/metadata.xml
new file mode 100644
index 000000000000..3911f0748f20
--- /dev/null
+++ b/dev-python/pyqwt/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ PyQwt is a set of Python bindings for the Qwt C++ class library which
+ extends the Qt framework with widgets for scientific and engineering
+ applications. It provides a widget to plot 2-dimensional data and
+ various widgets to display and control bounded or unbounded floating
+ point values.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyqwt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild b/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild
new file mode 100644
index 000000000000..08afe31210c0
--- /dev/null
+++ b/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic python-r1
+
+MY_P="PyQwt-${PV}"
+DESCRIPTION="Python bindings for the Qwt library"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://pyqwt.sourceforge.net/"
+
+SLOT="5"
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm ia64 x86"
+IUSE="debug doc examples svg"
+
+RDEPEND="
+ x11-libs/qwt:5[svg?]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${DEPEND}
+ dev-python/sip[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/configure"
+
+src_prepare() {
+ python_copy_sources
+ append-flags -fPIC
+}
+
+src_configure() {
+ configuration() {
+ local myonf=()
+ use debug && myconf+=( --debug )
+
+ cd "${BUILD_DIR}" || die
+ # '-j' option can be buggy.
+ "${PYTHON}" configure.py \
+ --extra-cflags="${CFLAGS}" \
+ --extra-cxxflags="${CXXFLAGS}" \
+ --extra-lflags="${LDFLAGS}" \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt \
+ ${myconf[@]} \
+ || die "configure.py failed"
+
+ # Avoid stripping of the libraries.
+ sed -i -e "/strip/d" {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ compilation() {
+ cd "${BUILD_DIR}" || die
+ default
+ }
+ python_foreach_impl compilation
+
+ if use doc; then
+ cd "${S}"/../sphinx || die
+ emake
+ fi
+}
+
+src_install() {
+ installation() {
+ cd "${BUILD_DIR}" || die
+ emake DESTDIR="${D}" install
+ }
+ python_foreach_impl installation
+
+ cd "${S}"/.. || die
+
+ dodoc ANNOUNCEMENT-${PV} README
+
+ use doc && dodoc -r sphinx/build/.
+ if use examples; then
+ docinto examples
+ dodoc -r qt4examples/.
+ fi
+}