summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-02 06:43:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-02 06:50:41 +0200
commita1e87887d067ae166b69f76c7019986cec74a2ea (patch)
treedd5ee2585749c098eef6508667e4e6f27b12fdf3 /dev-python/pyjwt
parentdev-python/iminuit: Bump to 2.28.0 (diff)
downloadgentoo-a1e87887d067ae166b69f76c7019986cec74a2ea.tar.gz
gentoo-a1e87887d067ae166b69f76c7019986cec74a2ea.tar.bz2
gentoo-a1e87887d067ae166b69f76c7019986cec74a2ea.zip
dev-python/pyjwt: Bump to 2.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.9.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 95bc4c64c3f3..84a290b246ea 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1 +1,2 @@
DIST PyJWT-2.8.0.tar.gz 78313 BLAKE2B b5031ec0ea672ef2dffc077aba6c781a20a7497257a16241841c0e0158017370581e3c9785d930772290c25fc9029e71a5d8744d999b135b29715a4f35720508 SHA512 74e74cf8c78494a9e51a2a186347361388031d5c0d0864df2a5d051621d9d31dff617ab1d7ebb4a829cc7d409d196e1bdb3b361ec888b6c14f1abea77544475e
+DIST pyjwt-2.9.0.tar.gz 78825 BLAKE2B f8228502944e6fc50412533c0c3f6d03fe7538dae8e1c42dd01d6b4419ef165f98125712e48d5c5b7f0d7eced36b6a84a69b9da549fe5e57effcba652f78faec SHA512 10d0344e05a142b3edadc970dd5cebc5eada1f638a599ca0f566c00149d67626c7fa1bbe668a56bc93048669df3af266c581f4872bf5756a4cc526f4b831dfc1
diff --git a/dev-python/pyjwt/pyjwt-2.9.0.ebuild b/dev-python/pyjwt/pyjwt-2.9.0.ebuild
new file mode 100644
index 000000000000..d7c6984ef15b
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="PyJWT"
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="
+ https://github.com/jpadilla/pyjwt/
+ https://pypi.org/project/PyJWT/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !dev-python/python-jwt
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_jwks_client.py::TestPyJWKClient::test_get_jwt_set_sslcontext_default
+)
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}