summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-27 03:40:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-27 03:40:12 +0100
commit1709509b7fbf3f0166257994cb6a12f61cc278f5 (patch)
treeb03209de01dc22c5c3c4c00d6b5d6ada46eb3345 /dev-python/pyicu
parentsci-libs/lrslib: add 073 (diff)
downloadgentoo-1709509b7fbf3f0166257994cb6a12f61cc278f5.tar.gz
gentoo-1709509b7fbf3f0166257994cb6a12f61cc278f5.tar.bz2
gentoo-1709509b7fbf3f0166257994cb6a12f61cc278f5.zip
dev-python/pyicu: Bump to 2.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.14.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index 7894c7e93431..0f035836baa8 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
DIST pyicu-v2.13.1.tar.bz2 196960 BLAKE2B 8faf5faf1fb8246c07dfb5ace5c2ad7cf8c86a183e0fa48288c81f7de47422152af2a44392972d818542370ea6f91c592d8d520b49848389109e6b2c1aa3ee17 SHA512 f85dd31b6a505efd32c3d0ea1c996b51b9da8cdc7ce3b88c997573a4ef1506a6af7b76f48f86d64e8993878ae25abcd95b04f40ba7a4f38fbf3b4cefd79b8066
+DIST pyicu-v2.14.tar.bz2 198031 BLAKE2B f0b4e4162df9854c68dd61aae9b57f97793283e57658327cc41d8f71661dbe45e1b2af1fceb214187d031906a769f70e16085764af30b28ec190097f0f5663d7 SHA512 671a02c69c2ad5b0d6dec5eceeda87500d6c362cd8066147b5027d0b37211025deb7e231a29f977c98f9ed22201b554988418627aeb7a10164ebcdeaacab2cef
diff --git a/dev-python/pyicu/pyicu-2.14.ebuild b/dev-python/pyicu/pyicu-2.14.ebuild
new file mode 100644
index 000000000000..81bb2bcd0dc6
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.14.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test
+}