summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 08:22:22 +0000
committerSam James <sam@gentoo.org>2023-02-17 08:23:50 +0000
commit56a6f5e5bfaa20268d5817eaa184561c409e3a13 (patch)
treeb87c7a5e62e44a923e1bfcfa45404102838bf1cc /dev-python/pygccxml
parentdev-libs/castxml: use llvm.eclass (diff)
downloadgentoo-56a6f5e5bfaa20268d5817eaa184561c409e3a13.tar.gz
gentoo-56a6f5e5bfaa20268d5817eaa184561c409e3a13.tar.bz2
gentoo-56a6f5e5bfaa20268d5817eaa184561c409e3a13.zip
dev-python/pygccxml: enable py3.11, PEP517
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild b/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..970734b16889
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A specialized XML reader to navigate C++ declarations"
+HOMEPAGE="https://github.com/CastXML/pygccxml"
+SRC_URI="https://github.com/CastXML/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/castxml
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme