summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-11-20 16:14:38 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-11-20 16:15:17 +0100
commit755264ae96140375e73dd274f7aa25bdfd0ef11a (patch)
tree5681e58ae0ab4c56ecfea3040bdb8d692977036f /dev-python/pygccxml
parentdev-haskell/foldl: fix building without USE=test (diff)
downloadgentoo-755264ae96140375e73dd274f7aa25bdfd0ef11a.tar.gz
gentoo-755264ae96140375e73dd274f7aa25bdfd0ef11a.tar.bz2
gentoo-755264ae96140375e73dd274f7aa25bdfd0ef11a.zip
dev-python/pygccxml: add 2.4.0
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest1
-rw-r--r--dev-python/pygccxml/files/pygccxml-2.4.0-pyproject.patch10
-rw-r--r--dev-python/pygccxml/pygccxml-2.4.0.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
index c98076c800aa..c3d47e08d233 100644
--- a/dev-python/pygccxml/Manifest
+++ b/dev-python/pygccxml/Manifest
@@ -1,2 +1,3 @@
DIST pygccxml-2.2.1.gh.tar.gz 3170283 BLAKE2B b53123c59d098f56d97841225d10ffd4156b993244e48c4ad30e2f62b6d95d69e0ae4bbfc86bb492e88e8f52d916401f29a6ec7024277d1e32b3af691a12e919 SHA512 32013617d4d632617b616d3787631c5b09da441a87bb15b88e3b287f17b85e1388308e85dd385276966ac09114536a5863edd5fbb96539547783fd2d41c6e8ce
DIST pygccxml-2.3.0.gh.tar.gz 3165248 BLAKE2B 177591d818f3ff91b7981ee1b1af9d03f79869508cddd03ece8f3b5e447982dc2d9434fa42db290c98d8c5fb4f4ee4ae7ef86e2b065dc28ba4b7843a36cad4e1 SHA512 6c5710c842c8e6101af73335ea66dc18ae86861f9cd5c59b4aa1037f60914934ba22a821d7f35cf954f5c40800433bacfc0d4bd0ae1bb5946a4dd950c606ceea
+DIST pygccxml-2.4.0.gh.tar.gz 3165189 BLAKE2B 855b0b6313be29e7719abe4cc6e654904657c11bfd7310d647227ce9d7760821eeb348dcd9892afbcc3d467db96daaf3010e92803fe28962db9a255cf81eae46 SHA512 48bf4887344c68d0a93a3908cc0a744f3d6a74dce92be88527e85cf7ba1a46f88560730dce0b858f31523cada836aad40461de935c5c2a041de0fa2ae5e38c30
diff --git a/dev-python/pygccxml/files/pygccxml-2.4.0-pyproject.patch b/dev-python/pygccxml/files/pygccxml-2.4.0-pyproject.patch
new file mode 100644
index 000000000000..ba00ed45ad34
--- /dev/null
+++ b/dev-python/pygccxml/files/pygccxml-2.4.0-pyproject.patch
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2023-11-20 13:59:55.807461669 +0100
++++ pyproject.toml 2023-11-20 14:00:37.335886130 +0100
+@@ -1,5 +1,6 @@
+ [build-system]
+-requires = ["setuptools", "wheel"]
++requires = ["setuptools"]
++build-backend = "setuptools.build_meta"
+
+ [project]
+ name = "pygccxml"
diff --git a/dev-python/pygccxml/pygccxml-2.4.0.ebuild b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
new file mode 100644
index 000000000000..7c80f9e6c423
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A specialized XML reader to navigate C++ declarations"
+HOMEPAGE="https://github.com/CastXML/pygccxml"
+SRC_URI="https://github.com/CastXML/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/castxml
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+
+python_prepare_all() {
+ eapply -p0 "${FILESDIR}/${PN}-2.4.0-pyproject.patch"
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}