summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pycountry
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/Manifest2
-rw-r--r--dev-python/pycountry/metadata.xml10
-rw-r--r--dev-python/pycountry/pycountry-1.10.ebuild32
-rw-r--r--dev-python/pycountry/pycountry-1.12.ebuild31
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
new file mode 100644
index 000000000000..29974bf23ce5
--- /dev/null
+++ b/dev-python/pycountry/Manifest
@@ -0,0 +1,2 @@
+DIST pycountry-1.10.zip 8140587 SHA256 29bd07e5f0d0471c260cea14e2ca4b7d705228ebb024b4de139dc87795576e67 SHA512 076de329c5b9d7626fbf0aace654504a2cd2d1d7bdf2ec89ba4763b38b756a6e75c7f3032c4b8785693d291ace7a206673cac1a457c4dd59e8c3ce1cd70d7d60 WHIRLPOOL 6c282d419da375e00171345477a5867b1e61a345d56c8f4739ff34fabebf98a78a2d4880b3b2ef616e00468124e1accd2efdbfac2c98bdf4c2db57d1d3e28fc5
+DIST pycountry-1.12.tar.gz 18606424 SHA256 dce2893ceac5d5264e7d0b6bf9f0421fb9ff87b7459d1c65a518fbcd826245e9 SHA512 6a9bfb47ce56098bc8f536afc5e671cd65304213df1e3c9754bcaac8e3cdb8293c75ec59649be5df8b974f36be333ed35fe4cd4d274baa183cfd6455d9241702 WHIRLPOOL 531fcfa4caeec4eda11c657e7a374d2668808ee9b94cb5192603049824fbd12a6999682a321d4c577f836acd9106f667f85312ec29e9d78fca74b7b93c297356
diff --git a/dev-python/pycountry/metadata.xml b/dev-python/pycountry/metadata.xml
new file mode 100644
index 000000000000..b170fed1253d
--- /dev/null
+++ b/dev-python/pycountry/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">ISO country, subdivision, language, currency and script definitions and
+ their translations</longdescription>
+ <upstream>
+ <remote-id type="pypi">pycountry</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycountry/pycountry-1.10.ebuild b/dev-python/pycountry/pycountry-1.10.ebuild
new file mode 100644
index 000000000000..5194cd611492
--- /dev/null
+++ b/dev-python/pycountry/pycountry-1.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO country, subdivision, language, currency and script definitions and their translations"
+HOMEPAGE="http://pypi.python.org/pypi/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~ppc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}
diff --git a/dev-python/pycountry/pycountry-1.12.ebuild b/dev-python/pycountry/pycountry-1.12.ebuild
new file mode 100644
index 000000000000..3a9ccc8f47b8
--- /dev/null
+++ b/dev-python/pycountry/pycountry-1.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO country, subdivision, language, currency and script definitions and their translations"
+HOMEPAGE="http://pypi.python.org/pypi/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~ppc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}