summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-22 22:14:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-22 22:33:22 +0100
commit13a7e546a8e586903a43386beb7b3eeb1068255e (patch)
treefaf02d569f8cb0033a2fb7dbec13a068e1bf993b /dev-python/prompt_toolkit
parentdev-python/setuptools: Bump to 54.2.0 (diff)
downloadgentoo-13a7e546a8e586903a43386beb7b3eeb1068255e.tar.gz
gentoo-13a7e546a8e586903a43386beb7b3eeb1068255e.tar.bz2
gentoo-13a7e546a8e586903a43386beb7b3eeb1068255e.zip
dev-python/prompt_toolkit: Bump to 3.0.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.18.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 36a270dc1d9f..86c6c516f2de 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,2 +1,3 @@
DIST prompt_toolkit-3.0.16.tar.gz 3033157 BLAKE2B 6f21544701f956a1e9ec29d049750dc47a6e3861e33a0ccc1e407185ece967c692d3f868e670779dadef3cdf5ec72bd6477e1b3ebfeddd84c267db94efa33f22 SHA512 fd8ebf4ceb61fb823a13bf81ebd6864e817541d08d0744eec8968afe9a9d44bfa95031fe7c53accc81a1612253041e742957aee3718dd18c437d8c3e1b616f35
DIST prompt_toolkit-3.0.17.tar.gz 3033301 BLAKE2B 86ba94f2e0c9e998c53e5e4ed12961c85c667b6d0356d17cfcb1856aef933f88c1c525507e76a833970444a787641c7316bc7496787ffcd61102945ae91b73bb SHA512 ef78b3aaf953f20a035f8a1f58262a8e4c1ae6b88c02c523bc51237bed22f52e229488d0113901bcd94835cc7120ccb4beb75cc9c9d99dde4e8f21df7bfde8a4
+DIST prompt_toolkit-3.0.18.tar.gz 3034754 BLAKE2B 27334b7009fc162af67a1fa14bd30c76efed6a333c5c93f3100a2c9ad3299a1139c3c3cf530e7e048b5700c0dc4ec1087d1aecd5412785b09221ea2d55796008 SHA512 be2dbd72a1e08553c0e50453958b6085a7d743464acd02b303e5002e1174d672d2cadd7a992e71d0445aa2f2be7565411ae4d00c3677c275eca056a20ad9efc8
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.18.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.18.ebuild
new file mode 100644
index 000000000000..fe628251486f
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.18.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest