summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 22:33:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 22:57:03 +0200
commit02231cc319d023f204b8daf8427117f7cdd7af76 (patch)
treec9d9b0c81afe9e573f5000357b470d757da6d283 /dev-python/portend
parentdev-python/pytest-helpers-namespace: Bump to 2021.12.29 (diff)
downloadgentoo-02231cc319d023f204b8daf8427117f7cdd7af76.tar.gz
gentoo-02231cc319d023f204b8daf8427117f7cdd7af76.tar.bz2
gentoo-02231cc319d023f204b8daf8427117f7cdd7af76.zip
dev-python/portend: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/portend')
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/portend-3.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
index d404b28f39c5..e5e5075ddec8 100644
--- a/dev-python/portend/Manifest
+++ b/dev-python/portend/Manifest
@@ -1 +1,2 @@
DIST portend-3.0.0.tar.gz 9439 BLAKE2B 50c6455c8d5ad51e1b523d4aa150ffc5a607a35d3c6fed4d2f686f2fa7fd7eefbe00bf0a033b9178b205e5bba5650e3de484c66d824f41b259ea031b985d2ccd SHA512 7228d454e7d22317de3462edb1e2f1b7fcf29e4601c9373709d80260ea5964c0dd4fbc39543e27a7f375b478ca119b285e47fac6ffda41401399cbe7bf485c8c
+DIST portend-3.1.0.tar.gz 9448 BLAKE2B d9391577ecc6f878ebbceb07266f06902352076fb61164b5e905a3ed0a557ce5dafcd8e3c77a099aab97fa576aee5be024d98f457e3b333aa80dbd534167218b SHA512 017dff68ea85f48d19398f71fbd8189329ca9c27c05d8599dd5e53632eb5ddc6dea322e94c924a0653f25f042a3c8ee1cda5f8450b02f3406a72036d54cd1aaf
diff --git a/dev-python/portend/portend-3.1.0.ebuild b/dev-python/portend/portend-3.1.0.ebuild
new file mode 100644
index 000000000000..756113e74c5e
--- /dev/null
+++ b/dev-python/portend/portend-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="
+ https://github.com/jaraco/portend/
+ https://pypi.org/project/portend/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/tempora-1.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest