summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gmail.com>2016-05-07 09:17:09 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-07 20:10:56 +0800
commitb222d3eac50a8381c9095a4aaa4137e910cfc559 (patch)
tree662c56526439c2a33ba35d848ac768086a4360a4 /dev-python/polib/polib-1.0.7.ebuild
parentapp-office/libreoffice-bin-debug: amd64 stable, bug #580672 (diff)
downloadgentoo-b222d3eac50a8381c9095a4aaa4137e910cfc559.tar.gz
gentoo-b222d3eac50a8381c9095a4aaa4137e910cfc559.tar.bz2
gentoo-b222d3eac50a8381c9095a4aaa4137e910cfc559.zip
dev-python/polib: version bump, vn. 1.0.7
Closes: https://github.com/gentoo/gentoo/pull/1423 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/polib/polib-1.0.7.ebuild')
-rw-r--r--dev-python/polib/polib-1.0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.0.7.ebuild b/dev-python/polib/polib-1.0.7.ebuild
new file mode 100644
index 000000000000..e7826f3474ae
--- /dev/null
+++ b/dev-python/polib/polib-1.0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}