summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 18:13:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 18:40:43 +0200
commitad0ea40042374926f525cb14737c878d93086d78 (patch)
treec1698f2988770bd9cebbb112f86b2d669a60bc22 /dev-python/poetry-core
parentdev-python/griffe: Bump to 0.34.0 (diff)
downloadgentoo-ad0ea40042374926f525cb14737c878d93086d78.tar.gz
gentoo-ad0ea40042374926f525cb14737c878d93086d78.tar.bz2
gentoo-ad0ea40042374926f525cb14737c878d93086d78.zip
dev-python/poetry-core: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest1
-rw-r--r--dev-python/poetry-core/poetry-core-1.7.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 60c77ada3bf6..73abc20be6db 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1 +1,2 @@
DIST poetry-core-1.6.1.gh.tar.gz 477291 BLAKE2B 4e1bd77302005d344693fe7a08b0c55e8a9ea0aad3112915a18950e40cc51116740b9eff5ae851b1d7280454716e3a86b1d8d37d85749f64fcef3bc726eeaf83 SHA512 53db0e4f4d5bc6ed2b201cd88a84e07dc6421e910292b8b5efb0dcce1af6e8c62836458a6409aac0394b5063b7c4a6be93784b0bce8592d74f61800f54916706
+DIST poetry-core-1.7.0.gh.tar.gz 459637 BLAKE2B af42d3e44ccecfa2746fcde1f7c48a4a6376d3391ebd9b660658593c32058bc812460ed1df4999f18c929724c2750a13b8ca44d92791c34cef8544862e8c061a SHA512 cbad311ed53a4b39b027674e8c76cf8822b0cc33b69eca3d79a31e910111efba5021b156d95f51327dca24d584bd96ec1a8cde23b3912e4ed6ca66b11e1bce9b
diff --git a/dev-python/poetry-core/poetry-core-1.7.0.ebuild b/dev-python/poetry-core/poetry-core-1.7.0.ebuild
new file mode 100644
index 000000000000..6c7dfcec450c
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.7.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+# (note that some are indirect deps)
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.21[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON} (unported deps)"
+ return
+ fi
+
+ epytest
+}