summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-16 13:58:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-16 19:21:38 +0100
commit3426025df58d68d178a707584ef47c18a759cce1 (patch)
treeee238cb03fca61e759a1b1b42d2cefeb845d5ff5 /dev-python/platformdirs
parentdev-python/pythran: Bump to 0.12.1 (diff)
downloadgentoo-3426025df58d68d178a707584ef47c18a759cce1.tar.gz
gentoo-3426025df58d68d178a707584ef47c18a759cce1.tar.bz2
gentoo-3426025df58d68d178a707584ef47c18a759cce1.zip
dev-python/platformdirs: Port to flit_core to resolve bootstrap
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild b/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild
new file mode 100644
index 000000000000..dbbb346e5305
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.6.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}