summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-06-30 10:22:56 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-30 10:22:56 +0200
commit22e842e727e7ca3827b79f22eb7b8bed5bc59eae (patch)
tree20b93536507dbc3226531234465aeb87cbac3739 /dev-python/pkgconfig
parentmedia-sound/abcmidi: removed obsolete 2021.06.27 (diff)
downloadgentoo-22e842e727e7ca3827b79f22eb7b8bed5bc59eae.tar.gz
gentoo-22e842e727e7ca3827b79f22eb7b8bed5bc59eae.tar.bz2
gentoo-22e842e727e7ca3827b79f22eb7b8bed5bc59eae.zip
dev-python/pkgconfig: Fix brittle test sorting order
Closes: https://bugs.gentoo.org/799290 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/pkgconfig')
-rw-r--r--dev-python/pkgconfig/files/pkgconfig-1.5.4-brittle-tests.patch14
-rw-r--r--dev-python/pkgconfig/pkgconfig-1.5.4.ebuild2
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/pkgconfig/files/pkgconfig-1.5.4-brittle-tests.patch b/dev-python/pkgconfig/files/pkgconfig-1.5.4-brittle-tests.patch
new file mode 100644
index 000000000000..05ba21f22acc
--- /dev/null
+++ b/dev-python/pkgconfig/files/pkgconfig-1.5.4-brittle-tests.patch
@@ -0,0 +1,14 @@
+--- a/test_pkgconfig.py
++++ b/test_pkgconfig.py
+@@ -138,9 +138,9 @@
+ def test_configure_extension():
+ ext = Extension('foo', ['foo.c'])
+ pkgconfig.configure_extension(ext, 'fake-gtk+-3.0 fake-python')
+- assert ext.extra_compile_args == [
++ assert sorted(ext.extra_compile_args) == [
+ '-DGSEAL_ENABLE', '-I/usr/include/gtk-3.0','-I/usr/include/python2.7']
+- assert ext.extra_link_args == [
++ assert sorted(ext.extra_link_args) == [
+ '-L/usr/lib_gtk_foo', '-L/usr/lib_python_foo', '-lgtk-3', '-lpython2.7']
+
+
diff --git a/dev-python/pkgconfig/pkgconfig-1.5.4.ebuild b/dev-python/pkgconfig/pkgconfig-1.5.4.ebuild
index 086dfe2434ce..d4c0fd9d2b37 100644
--- a/dev-python/pkgconfig/pkgconfig-1.5.4.ebuild
+++ b/dev-python/pkgconfig/pkgconfig-1.5.4.ebuild
@@ -18,3 +18,5 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="virtual/pkgconfig"
distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-brittle-tests.patch )