summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 22:28:04 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 23:38:32 -0400
commitd9c8635bc6ee81573cbdd50a4bc212cd6244062b (patch)
tree70edb1e0c40ee88abb06ff2b2167f7429a5864eb /dev-python/pip
parentunpacker.eclass: disable path expansion while parsing SRC_URI #654960 (diff)
downloadgentoo-d9c8635bc6ee81573cbdd50a4bc212cd6244062b.tar.gz
gentoo-d9c8635bc6ee81573cbdd50a4bc212cd6244062b.tar.bz2
gentoo-d9c8635bc6ee81573cbdd50a4bc212cd6244062b.zip
dev-python/pip: version bump to 10.0.1
Closes: https://bugs.gentoo.org/578988 Closes: https://bugs.gentoo.org/621584
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/files/pip-10.0.1-disable-system-install.patch18
-rw-r--r--dev-python/pip/files/pip-10.0.1-disable-version-check.patch19
-rw-r--r--dev-python/pip/pip-10.0.1.ebuild48
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index d365e0ca3882..ca3c8caf9d88 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,2 +1,3 @@
+DIST pip-10.0.1.tar.gz 1246072 BLAKE2B e08607be43e1d7b9c7bbc12dff73bc3170953f48f8f7439a0b27b9d540f23eb3bca7873211a5f1448b5cedd6e8e12983af6fa4666bba3ac4700059d170036733 SHA512 983cce8375ff0304263209c69be16e5be7a58af340b8c3ffddd64fcea130b2f8f8a98305ab31e9c3eed9a0d039c73777c88bde3bf2ea1e184fa3e0a2faa97fd4
DIST pip-7.1.2.tar.gz 1049170 BLAKE2B 1461abba4cb80a9a4e806675ca2d996dedeeb8fb38f05b618f98f400475405da018ea6e75663c21b7b7eb5091408d602a3127afeea9a4bd29f075e5eb8042ad0 SHA512 78082afe6b559bf87f91ae9b6d304cfbfce00206e09be42fdae9d449a55cd8d968df6873e834191d0b0e6baae29e72eb3eee42386ff7c5dc9c29b6c28b754449
DIST pip-9.0.1.tar.gz 1197370 BLAKE2B 3618161690d5e0a38d141f9b51baea4aaa3fdc225664ef180bbeecf6e2df95e9ea4f97c63fe3a68f84f4fb5ebcc74e316827253c7e07b03565e58113bbaa918a SHA512 ee59efb4b009ff6543b7afdea99b9cbbee1981ecc03af586acda76674024d3b66dab23049e68f3da9448734984619fc1eaba6e965c9dd3d731973376c8a42e25
diff --git a/dev-python/pip/files/pip-10.0.1-disable-system-install.patch b/dev-python/pip/files/pip-10.0.1-disable-system-install.patch
new file mode 100644
index 000000000000..776d395b7b94
--- /dev/null
+++ b/dev-python/pip/files/pip-10.0.1-disable-system-install.patch
@@ -0,0 +1,18 @@
+install: Raise an error to avoid breaking python-exec
+
+Running pip without --target, --root, or --user will result in packages
+being installed systemwide. This has a tendency to break python-exec if
+setuptools gets installed or upgraded.
+
+--- pip-10.0.1/src/pip/_internal/commands/install.py
++++ pip-10.0.1/src/pip/_internal/commands/install.py
+@@ -202,6 +202,9 @@
+ if options.upgrade:
+ upgrade_strategy = options.upgrade_strategy
+
++ if not options.use_user_site and not options.target_dir and not options.root_path:
++ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
++
+ if options.build_dir:
+ options.build_dir = os.path.abspath(options.build_dir)
+
diff --git a/dev-python/pip/files/pip-10.0.1-disable-version-check.patch b/dev-python/pip/files/pip-10.0.1-disable-version-check.patch
new file mode 100644
index 000000000000..ad146dc1507f
--- /dev/null
+++ b/dev-python/pip/files/pip-10.0.1-disable-version-check.patch
@@ -0,0 +1,19 @@
+Don't check for new versions of pip.
+
+--- pip-10.0.1/src/pip/_internal/basecommand.py
++++ pip-10.0.1/src/pip/_internal/basecommand.py
+@@ -255,14 +255,6 @@
+
+ return UNKNOWN_ERROR
+ finally:
+- # Check if we're using the latest version of pip available
+- if (not options.disable_pip_version_check and not
+- getattr(options, "no_index", False)):
+- with self._build_session(
+- options,
+- retries=0,
+- timeout=min(5, options.timeout)) as session:
+- pip_version_check(session, options)
+ # Avoid leaking loggers
+ for handler in set(logging.root.handlers) - original_root_handlers:
+ # this method benefit from the Logger class internal lock
diff --git a/dev-python/pip/pip-10.0.1.ebuild b/dev-python/pip/pip-10.0.1.ebuild
new file mode 100644
index 000000000000..bd0c75e2b391
--- /dev/null
+++ b/dev-python/pip/pip-10.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="ssl,threads(+)"
+
+inherit eutils bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="https://pip.pypa.io/ https://pypi.org/project/pip/ https://github.com/pypa/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="-vanilla"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-10.0.1-disable-version-check.patch"
+ )
+ if ! use vanilla; then
+ PATCHES+=( "${FILESDIR}/pip-10.0.1-disable-system-install.patch" )
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ "${PYTHON}" -m pip completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ "${PYTHON}" -m pip completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}