summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 18:35:19 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 18:36:02 +0100
commitd96d2b5c981aa4c340626f2dba5bc8457280689c (patch)
treef4ba44dc924086bf9e616ffa9578c3d7539cc221 /dev-python/nose
parentnet-voip/telepathy-salut: Flatten twisted dep (diff)
downloadgentoo-d96d2b5c981aa4c340626f2dba5bc8457280689c.tar.gz
gentoo-d96d2b5c981aa4c340626f2dba5bc8457280689c.tar.bz2
gentoo-d96d2b5c981aa4c340626f2dba5bc8457280689c.zip
dev-python/nose: Coverage supports py3.8 now
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/nose-1.3.7-r4.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/dev-python/nose/nose-1.3.7-r4.ebuild b/dev-python/nose/nose-1.3.7-r4.ebuild
index e09fa46958b6..1c0a751bc7f4 100644
--- a/dev-python/nose/nose-1.3.7-r4.ebuild
+++ b/dev-python/nose/nose-1.3.7-r4.ebuild
@@ -22,22 +22,15 @@ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x
IUSE="coverage doc examples test"
RESTRICT="!test? ( test )"
-COVERAGE_IMPLS=( -2 python3_{5,6,7} pypy3 )
REQUIRED_USE="
- coverage? ( || ( $(python_gen_useflags "${COVERAGE_IMPLS[@]}") ) )
doc? ( || ( $(python_gen_useflags 'python2*') ) )"
RDEPEND="
- coverage? (
- $(python_gen_cond_dep 'dev-python/coverage[${PYTHON_USEDEP}]' \
- "${COVERAGE_IMPLS[@]}")
- )"
+ coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-0.6[$(python_gen_usedep 'python2*')] )
test? (
- $(python_gen_cond_dep '
- dev-python/coverage[${PYTHON_USEDEP}]
- ' "${COVERAGE_IMPLS[@]}")
+ dev-python/coverage[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/twisted[${PYTHON_USEDEP}]
' python2_7 python3_{6,7})