summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-12-21 08:21:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-21 09:11:11 +0100
commitc94f52813a08f01981fed0a2109ec760b82b487d (patch)
tree46f394564f9adc0c3d00d274312a42e178c29e8b /dev-python/nextinspace
parentxfce-extra/xfce4-screensaver: Bump to 4.18.4 (diff)
downloadgentoo-c94f52813a08f01981fed0a2109ec760b82b487d.tar.gz
gentoo-c94f52813a08f01981fed0a2109ec760b82b487d.tar.bz2
gentoo-c94f52813a08f01981fed0a2109ec760b82b487d.zip
dev-python/nextinspace: add 3.0.1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nextinspace')
-rw-r--r--dev-python/nextinspace/Manifest1
-rw-r--r--dev-python/nextinspace/nextinspace-3.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nextinspace/Manifest b/dev-python/nextinspace/Manifest
index 44820474adaa..fd04f35727ab 100644
--- a/dev-python/nextinspace/Manifest
+++ b/dev-python/nextinspace/Manifest
@@ -1,2 +1,3 @@
DIST nextinspace-2.0.5.gh.tar.gz 48406 BLAKE2B 6f6e2c95fc1a5a8175faca4df0a51de9996ca24847926dc35b94d0e4bd5c9de880ad757606309f622f41c825d0c2e46c587f255573b4df70fe35c937148af9d7 SHA512 c8f55446d9eea0409afb8a8ddb41001b18b55d9105d007b306717a3d932ea1b03ecb2363d0deb42ec8da1cc245b77ffb18cee6ec3474121c15c4c9b79ff80405
DIST nextinspace-3.0.0.gh.tar.gz 55095 BLAKE2B 02140cbfaeca9fd4cb19fefd40448fc5ffbed19a8e5bcb448800b1c5917d7873be69e0aab5c4d96acf4dfb7fc57b780420de19dc38a523b5ca38c9847cfa0263 SHA512 fa1d20401b7ed910e0c65c9010062cf6d1ffe7e73c09b47f42b19ab1bfbb74612cb7405571e4db0404de81e66211799f38b6654763222643f66e63176e4a72ab
+DIST nextinspace-3.0.1.gh.tar.gz 55101 BLAKE2B aeec5e34e6ae611d4f693dde10b14430d46853949c6e5d81aa90a842da670a156ecf3216c09d70f40279836155fe097c85c82e05a3e5c31d5457409f41a62f29 SHA512 92aa209e36eeed742cbfec99456aa452a164ffd97c87d6a17271c1731d9e4cdca1e616217ea6fdd347356b68644cc8fa3035228877324a7d180f764b6f8b012e
diff --git a/dev-python/nextinspace/nextinspace-3.0.1.ebuild b/dev-python/nextinspace/nextinspace-3.0.1.ebuild
new file mode 100644
index 000000000000..5d72a32bb012
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-3.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest