summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-12-19 17:14:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-19 19:37:16 +0100
commit4f5f4282bc3abdf3b537c8aa23a10c48f4ba9c90 (patch)
treec35469fbdb7b245790dd8578717a599913d789e1 /dev-python/nextinspace
parentsys-kernel/vanilla-sources: add 6.6.67 (diff)
downloadgentoo-4f5f4282bc3abdf3b537c8aa23a10c48f4ba9c90.tar.gz
gentoo-4f5f4282bc3abdf3b537c8aa23a10c48f4ba9c90.tar.bz2
gentoo-4f5f4282bc3abdf3b537c8aa23a10c48f4ba9c90.zip
dev-python/nextinspace: add 3.0.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nextinspace')
-rw-r--r--dev-python/nextinspace/Manifest1
-rw-r--r--dev-python/nextinspace/files/nextinspace-3.0.0-license.patch20
-rw-r--r--dev-python/nextinspace/nextinspace-3.0.0.ebuild39
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/nextinspace/Manifest b/dev-python/nextinspace/Manifest
index ca45cfafa5b3..44820474adaa 100644
--- a/dev-python/nextinspace/Manifest
+++ b/dev-python/nextinspace/Manifest
@@ -1 +1,2 @@
DIST nextinspace-2.0.5.gh.tar.gz 48406 BLAKE2B 6f6e2c95fc1a5a8175faca4df0a51de9996ca24847926dc35b94d0e4bd5c9de880ad757606309f622f41c825d0c2e46c587f255573b4df70fe35c937148af9d7 SHA512 c8f55446d9eea0409afb8a8ddb41001b18b55d9105d007b306717a3d932ea1b03ecb2363d0deb42ec8da1cc245b77ffb18cee6ec3474121c15c4c9b79ff80405
+DIST nextinspace-3.0.0.gh.tar.gz 55095 BLAKE2B 02140cbfaeca9fd4cb19fefd40448fc5ffbed19a8e5bcb448800b1c5917d7873be69e0aab5c4d96acf4dfb7fc57b780420de19dc38a523b5ca38c9847cfa0263 SHA512 fa1d20401b7ed910e0c65c9010062cf6d1ffe7e73c09b47f42b19ab1bfbb74612cb7405571e4db0404de81e66211799f38b6654763222643f66e63176e4a72ab
diff --git a/dev-python/nextinspace/files/nextinspace-3.0.0-license.patch b/dev-python/nextinspace/files/nextinspace-3.0.0-license.patch
new file mode 100644
index 000000000000..0f1708777ff7
--- /dev/null
+++ b/dev-python/nextinspace/files/nextinspace-3.0.0-license.patch
@@ -0,0 +1,20 @@
+commit 6e03e0f5cc94f039df06506a340b70d38860b84b
+Author: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Thu Dec 19 18:40:53 2024 +0100
+Upstream: https://github.com/gideonshaked/nextinspace/pull/18
+
+ Don't install LICENSE file in site-diretory
+
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -58,7 +58,9 @@ classifiers = [
+ "Programming Language :: Python :: 3 :: Only",
+ "Natural Language :: English"
+ ]
+-include = ["LICENSE"]
++include = [
++ { path = "LICENSE", format = "sdist" },
++]
+
+ [tool.poetry.dependencies]
+ python = "^3.10"
diff --git a/dev-python/nextinspace/nextinspace-3.0.0.ebuild b/dev-python/nextinspace/nextinspace-3.0.0.ebuild
new file mode 100644
index 000000000000..4017cac96b5e
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-license.patch"
+)
+
+distutils_enable_tests pytest