summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-12 06:04:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-12 06:35:34 +0200
commit4d6a86a360a985395080d3714753268b55b13573 (patch)
tree08dbe67f97e99b526a6082835c5da18eb7165412 /dev-python/networkx
parentapp-admin/awscli: Bump to 1.35.5 (diff)
downloadgentoo-4d6a86a360a985395080d3714753268b55b13573.tar.gz
gentoo-4d6a86a360a985395080d3714753268b55b13573.tar.bz2
gentoo-4d6a86a360a985395080d3714753268b55b13573.zip
dev-python/networkx: Bump to 3.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-3.4.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 7428d6361caa..c03edfc30b75 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,3 +1,4 @@
DIST networkx-3.3.tar.gz 2126579 BLAKE2B 37d5d536e2564f9a219df70bb7f1b7c0717b99e9cdb7a4050aa321609a0ef34caecfda5a6ed8cb17f4d3b305b667adf8e40b58568dde8eb942d4a00b1ebdb255 SHA512 86306cabd7e15aa79cae4d84a42e8804b1e904fc2127725067a80e3ddf31f0fa72ebb9d21284018e72bdfc662c766a5be55564572aadaf7392dada7ea93d1ea4
+DIST networkx-3.4.1.tar.gz 2151310 BLAKE2B e61270372fc1a334a8d9484275a3da72e6f45c405b9e867efb67dc32b4a0fa8973b5ecaebf3eb7d978314252c5bd4096844bf1648337a53d051d99628c93ed08 SHA512 44ea25509398c837d9c90ee2a47c980eac3bf3efe2dbf83c8cad0952a9c4b7b08e9c5c7e41ac96f704ac6d38533efa7af449d39804c1eb3b78781bd3eaad47be
DIST networkx-3.4.tar.gz 2151262 BLAKE2B 77bdc5262b173b7ce566c2d55e9180eb796f9f57eba0725e122d3dd51c62ad1bf6eb02e6f9daea592c3fe59ca17a7589b53089fdd069729bfff56aebfe536ca1 SHA512 f86957669256313af31d6743b29ad80b918a64084bb39fde077c151b886cbe1cf9b93c801e6d72f78ec9a15e790af462f463cdc56e785385dfde22f11bdf0bf7
DIST networkx-3.4rc0.tar.gz 2146054 BLAKE2B 9a183740a97136c85c75c1f34c11a6a753c0b1fc418074bcb02388822ddd2b7f5a53fc8f3866736dfb9833a300cf2e5d0776cbdceefcabdf0470cc89e790948e SHA512 14f19e1e524b8e9dfa55ecab34fcbb426460e29633284ec62957abd143f54685ceae3993306f3beff3a33d3cb7f3e408be417971fde11c75827ef05d999dc5f0
diff --git a/dev-python/networkx/networkx-3.4.1.ebuild b/dev-python/networkx/networkx-3.4.1.ebuild
new file mode 100644
index 000000000000..b386d30100dd
--- /dev/null
+++ b/dev-python/networkx/networkx-3.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{10..13} )
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing optfeature pypi virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.6[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/matplotlib-3.7[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.24[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.11.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ if use x86 ; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/networkx/networkx/issues/5913 (bug #921958)
+ networkx/algorithms/approximation/tests/test_traveling_salesman.py::test_asadpour_tsp
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # virtx implies nonfatal
+ nonfatal epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "sci-libs/gdal[python]"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}