summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 05:34:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 06:07:24 +0200
commitc0aaae1ea6747aea074cf09b850e9e359c99be4f (patch)
treea42c834ea01392a95da638758c5e325a9858f649 /dev-python/nbformat
parentnet-misc/minidlna: Bump to 1.3.3 (diff)
downloadgentoo-c0aaae1ea6747aea074cf09b850e9e359c99be4f.tar.gz
gentoo-c0aaae1ea6747aea074cf09b850e9e359c99be4f.tar.bz2
gentoo-c0aaae1ea6747aea074cf09b850e9e359c99be4f.zip
dev-python/nbformat: Bump to 5.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.9.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 373a600c0250..a25fec331cdd 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1 +1,2 @@
DIST nbformat-5.8.0.tar.gz 140655 BLAKE2B e45b6fcc45fa01ceed49fba0b3a3fd749df6692e355156845cf69fd9d2e176332c61c89b5474ffa89d96da4d4453b668150e96ac266cddd254efdcb1a3b742a1 SHA512 f000db59701eec2fed8adba6c1b521bdfaf942bcd0dba2d8d6d79a7d28b078f4a29df05ca3f393c1651f3ddc6b3690f536928d6fff5937982cc52dd013bc6498
+DIST nbformat-5.9.0.tar.gz 140980 BLAKE2B e967ac0972dd2a5749694900002f9ada4171b5219249c3b6aa600fba97121aae0334516838c86b175064b0975a298fa9a1614dd2a458dd5d66ba832187731bd4 SHA512 c409feb3b6ae9b89b86d1c5e77a23a368776ccf9e62d606e2bb689927eca4d73c79a22e3f5e9e2beda78c201dc7485114e762872b305278c23c8129c7c65449b
diff --git a/dev-python/nbformat/nbformat-5.9.0.ebuild b/dev-python/nbformat/nbformat-5.9.0.ebuild
new file mode 100644
index 000000000000..d4cb983ceb55
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/nbformat-5.7.1-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)