summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-27 11:46:13 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-27 11:48:14 +0200
commit1da2d9a339dc70f7a21902684589dfd15bff4499 (patch)
treeebdacf2428bd9564e28bb91898de0b737742a5a4 /dev-python/nbclient
parentdev-python/qtconsole: enable py3.11 (diff)
downloadgentoo-1da2d9a339dc70f7a21902684589dfd15bff4499.tar.gz
gentoo-1da2d9a339dc70f7a21902684589dfd15bff4499.tar.bz2
gentoo-1da2d9a339dc70f7a21902684589dfd15bff4499.zip
dev-python/nbclient: enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/nbclient-0.7.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/nbclient/nbclient-0.7.0.ebuild b/dev-python/nbclient/nbclient-0.7.0.ebuild
index 343192040c27..90bf73d4d736 100644
--- a/dev-python/nbclient/nbclient-0.7.0.ebuild
+++ b/dev-python/nbclient/nbclient-0.7.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -45,3 +45,10 @@ EPYTEST_DESELECT=(
nbclient/tests/test_client.py::test_many_parallel_notebooks
'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
)
+
+python_test() {
+ # The tests run the pydevd debugger, the debugger prints a warning
+ # in python3.11 when frozen modules are being used.
+ # This warning makes the tests fail, silence it.
+ PYDEVD_DISABLE_FILE_VALIDATION=1 epytest
+}