summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:37:02 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:37:02 +0100
commitb27bee1c248cd1d475d9d23fd35f4af3c023785e (patch)
treecebfa4b2c519ebe2b00e2c7bebe29b1f1c2cae6a /dev-python/mkdocs-git-authors-plugin
parentdev-python/qdarkstyle: add version 3.0.3 (diff)
downloadgentoo-b27bee1c248cd1d475d9d23fd35f4af3c023785e.tar.gz
gentoo-b27bee1c248cd1d475d9d23fd35f4af3c023785e.tar.bz2
gentoo-b27bee1c248cd1d475d9d23fd35f4af3c023785e.zip
dev-python/mkdocs-git-authors-plugin: new dep of mkdocs-git-
revision-date-localized-plugin Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-git-authors-plugin/metadata.xml17
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild51
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
new file mode 100644
index 000000000000..793f6d69bbcf
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -0,0 +1 @@
+DIST mkdocs-git-authors-plugin-0.6.2.tar.gz 27623 BLAKE2B 7b0dd3b865b067b63e467fa75018a92cea8cfeabdeb66791664ea143ebecbb072110698f1366f917f390dd29c33794c7d2cc03e03bb84f8913b572d667e77b9d SHA512 75e4a4e6f3ca443257b5f61f5f0d9784cb4bb28a5a03412cde5c226da697117a29c2f4a3d1cac2aa362421f244fd56ea8580a923414a8e096bedc4502afcb5b0
diff --git a/dev-python/mkdocs-git-authors-plugin/metadata.xml b/dev-python/mkdocs-git-authors-plugin/metadata.xml
new file mode 100644
index 000000000000..1ac0758baa56
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">timvink/mkdocs-git-authors-plugin</remote-id>
+ <remote-id type="pypi">mkdocs-git-authors-plugin</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild
new file mode 100644
index 000000000000..f267258de4cb
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}