summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-06 13:23:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-06 14:22:29 +0100
commit718601ae567239b6073cf87ee722ff717235251b (patch)
treeab693183c618bffcfc7ce565cec71476155d9b38 /dev-python/isort
parentsys-apps/cpu-x: (diff)
downloadgentoo-718601ae567239b6073cf87ee722ff717235251b.tar.gz
gentoo-718601ae567239b6073cf87ee722ff717235251b.tar.bz2
gentoo-718601ae567239b6073cf87ee722ff717235251b.zip
dev-python/isort: Remove test dep on dev-python/pylama
Remove the test dependency on dev-python/pylama. It requires dev-python/pydocstyle that has been discontinued, and pylama itself seems quite dead as well. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/isort-5.12.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/isort/isort-5.12.0.ebuild b/dev-python/isort/isort-5.12.0.ebuild
index c9fcff720b34..6a9a23af7de4 100644
--- a/dev-python/isort/isort-5.12.0.ebuild
+++ b/dev-python/isort/isort-5.12.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -31,7 +31,6 @@ BDEPEND="
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/natsort[${PYTHON_USEDEP}]
- dev-python/pylama[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-vcs/git
)
@@ -63,5 +62,13 @@ python_test() {
# Excluded from upstream's test script
tests/unit/test_deprecated_finders.py
)
+
+ if ! has_version "dev-python/pylama[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/unit/test_importable.py
+ tests/unit/test_pylama_isort.py
+ )
+ fi
+
epytest tests/unit
}