summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-29 07:41:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-29 08:12:59 +0100
commit0b72e41ba101365f70b971785de2e1d333be03fd (patch)
tree4a363742df5b3281d8ed5ab9b621307076f7aae9 /dev-python/isort
parentdev-python/identify: Bump to 2.5.16 (diff)
downloadgentoo-0b72e41ba101365f70b971785de2e1d333be03fd.tar.gz
gentoo-0b72e41ba101365f70b971785de2e1d333be03fd.tar.bz2
gentoo-0b72e41ba101365f70b971785de2e1d333be03fd.zip
dev-python/isort: Bump to 5.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest1
-rw-r--r--dev-python/isort/isort-5.12.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 4d7f9756102c..6f431d1236dc 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1 +1,2 @@
DIST isort-5.11.4.gh.tar.gz 733368 BLAKE2B 82a9738cf48fd662c6128c7f58766e6b204d93fee73cbdd0d84850a62a1a714322dc6c31429a3b043401a963178c4aa3120e98c8f590f24799b75a92f9427798 SHA512 fd7dd8938cc700fa4a295bf1aabb9dc479e1b837e443e3210e4f2234316e207293eeb6f666b49ed2bc4f92942b3185de64439ce86ece201093072fee905766a8
+DIST isort-5.12.0.gh.tar.gz 743141 BLAKE2B a7f8deef02b57162eebe15b35e71382c654372a80dedba7eee63d0c9b0899c053fb517401585af17014db3cf9ed44089f6cbd1e2b0ed17393cc667de06bfbddd SHA512 ceb861d1a077be6fecd82fde775bded1fb676c77135e2004c92a6221762e0b3ff6c1071d17957e1add4062ec26ba6c9264e4905724f2c659339cbd0601f4b45e
diff --git a/dev-python/isort/isort-5.12.0.ebuild b/dev-python/isort/isort-5.12.0.ebuild
new file mode 100644
index 000000000000..1c237256715b
--- /dev/null
+++ b/dev-python/isort/isort-5.12.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="
+ https://github.com/PyCQA/isort/
+ https://pypi.org/project/isort/
+"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle tomli
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+ # leftover toml import used to determine .toml support
+ sed -i -e 's:import toml:toml = True:' tests/unit/test_isort.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit
+}