summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 17:07:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 18:10:24 +0200
commitd829195620d703e0b885132d60128bff73259e84 (patch)
treef07f6a3379ba4164ebd5b3bc776ef4a8ebae9296 /dev-python/irc
parentdev-python/rustworkx: Enable py3.13 w/ pyo3-ffi patch (diff)
downloadgentoo-d829195620d703e0b885132d60128bff73259e84.tar.gz
gentoo-d829195620d703e0b885132d60128bff73259e84.tar.bz2
gentoo-d829195620d703e0b885132d60128bff73259e84.zip
dev-python/irc: Bump to 20.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-20.4.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index 9d694b954d92..700bc270c538 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1 +1,2 @@
DIST irc-20.4.1.tar.gz 91229 BLAKE2B 05518a19821016e5a10173a5ee20a0d3cb6047eb87f4a153331bc8458abb365d27cde8ae02b1e7c12a86957adc7811511f61c516bdb1c6f0f03f4a5186524eb5 SHA512 e57e18c7c8111c883737cbaa176e0e895c182e43208ff784abf382bcab0b613287076ec35cfe266d78418e27b38a6443344b03bd90ea768c1c50ce0c32453d89
+DIST irc-20.4.2.tar.gz 91206 BLAKE2B 4a2b16581bc863774180e9fe67b564be50cfa3ea192999153426bbe883b5360ccaf053fab6e7a9fb47262d0a7f3f97a2dd2eab8f2a6f16223e4fd12b0f333f45 SHA512 18a767ad99cbc387b9c785da9334a96822092eb90e7fdb913af92cb7ea973fc2e54cb59942a025e33630ff3a78b6a52910a92c053daa4f25ef37d851f58a62e4
diff --git a/dev-python/irc/irc-20.4.2.ebuild b/dev-python/irc/irc-20.4.2.ebuild
new file mode 100644
index 000000000000..0a2a0ab2df22
--- /dev/null
+++ b/dev-python/irc/irc-20.4.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="
+ https://github.com/jaraco/irc/
+ https://pypi.org/project/irc/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/jaraco-logging[${PYTHON_USEDEP}]
+ dev-python/jaraco-stream[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-text-3.10[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ dodoc -r scripts
+ fi
+ distutils-r1_python_install_all
+}