summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-11 22:17:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-11 22:19:12 +0300
commit62e43120eecf9653c34c314259cdc8a2372a7c0c (patch)
tree4a7121bc624c456ffe531a599234f009fc65d7e5 /dev-python/iocapture
parentnet-misc/iputils: do not move 'ping' to /bin (diff)
downloadgentoo-62e43120eecf9653c34c314259cdc8a2372a7c0c.tar.gz
gentoo-62e43120eecf9653c34c314259cdc8a2372a7c0c.tar.bz2
gentoo-62e43120eecf9653c34c314259cdc8a2372a7c0c.zip
dev-python/iocapture: enable py3.10, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/iocapture')
-rw-r--r--dev-python/iocapture/iocapture-0.1.2-r3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2-r3.ebuild b/dev-python/iocapture/iocapture-0.1.2-r3.ebuild
new file mode 100644
index 000000000000..f3de73379f07
--- /dev/null
+++ b/dev-python/iocapture/iocapture-0.1.2-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Capture stdout, stderr easily"
+HOMEPAGE="https://pypi.org/project/iocapture/"
+SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="MIT"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest