summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-22 07:55:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-22 09:06:48 +0100
commitef88b267e4fdb8e6799066bd65c7fd6a66122e84 (patch)
treef813374a9fd0a213f5aae24cdf933aae256173a8 /dev-python/hypothesis
parentapp-i18n/ibus-m17n: drop old (diff)
downloadgentoo-ef88b267e4fdb8e6799066bd65c7fd6a66122e84.tar.gz
gentoo-ef88b267e4fdb8e6799066bd65c7fd6a66122e84.tar.bz2
gentoo-ef88b267e4fdb8e6799066bd65c7fd6a66122e84.zip
dev-python/hypothesis: Bump to 6.122.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.122.6.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index fce147bb6594..b6338bd53937 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-6.122.1.gh.tar.gz 9492677 BLAKE2B 66f89d2388cb34e5df95bc73af6925
DIST hypothesis-6.122.3.gh.tar.gz 9495681 BLAKE2B af743d0486d31590639216e60901eb7ee376dfcce18a9e130ea5061788d9c9d66f1ebcec23f144d41652581e50c30903aa9d697e304cfe05259c454c344f02e0 SHA512 8776f603682a3ef7c36bc47f6e36b64b0e01c37f4db80fe78d492a3e4d347b4ec1d9c87e6999069d2cb4b5ac7d33e0d1258055b679fcacc6812b256e6398f043
DIST hypothesis-6.122.4.gh.tar.gz 9495842 BLAKE2B 4a17e7096a1c86a13851af3d905839c53e0b8b15685a84bad9fbde5d74679e1153bcfe8dae6780bdaabcb3242990f4cd29d4eaf29f564eda4c09c01b4fdd5f98 SHA512 4828b35ca3c9a601303eb671e322d1c81afe079d0eb04d5518397310e5ee15a1e0bdc5c3fb252c34de8a5ad931992974a9bbe136ebebd10c26a52096febdda31
DIST hypothesis-6.122.5.gh.tar.gz 9499110 BLAKE2B 57de8290600ceadc408804d4ec5df7bc96977757dfb9039d894e39bef6c0a53fd3453ac86320353079c4835218557e5331a45894e5f61a60191c562c334827dc SHA512 67df638efaca6fccafba2305042a785c32ea532ac52336f55e38fe085351052386408399e0097572a9be546891212286228a12b48839892883284a4cee01ff33
+DIST hypothesis-6.122.6.gh.tar.gz 9499547 BLAKE2B 2d111698688050f3ce0d9cfdc1bc5b900b4d347b3733edac483e8e1b0b915b158903d055955893041c80064a0878d6a2a7aaafcf3b9b00c4c232567b9709aeae SHA512 3aa0d6a8ac033b6145b6ba831663074002bd67a793e8fe157e76d2768b2048d9864b82179667f7cb732444f09a5b178490b6eecb34d4c0460a164968b33c9f88
diff --git a/dev-python/hypothesis/hypothesis-6.122.6.ebuild b/dev-python/hypothesis/hypothesis-6.122.6.ebuild
new file mode 100644
index 000000000000..dde5562c67da
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.122.6.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -p rerunfailures --reruns=5 \
+ tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}