summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-07 07:10:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-07 07:10:15 +0100
commit67d78cad9cdc8d7f26a77af0f692344cab450f0d (patch)
tree5acaa71dcf4a55f853241c332e42cbcecdb1b9e6 /dev-python/httpx-socks
parentdev-python/tqdm: Bump to 4.67.0 (diff)
downloadgentoo-67d78cad9cdc8d7f26a77af0f692344cab450f0d.tar.gz
gentoo-67d78cad9cdc8d7f26a77af0f692344cab450f0d.tar.bz2
gentoo-67d78cad9cdc8d7f26a77af0f692344cab450f0d.zip
dev-python/httpx-socks: Bump to 0.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpx-socks')
-rw-r--r--dev-python/httpx-socks/Manifest1
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.9.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index cac3b106869d..11bbe304ba44 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1 +1,2 @@
DIST httpx-socks-0.9.1.gh.tar.gz 15210 BLAKE2B 88f38797110227c4e4f01fea7e47c9403573c3c06f6bd644858a6ad4947d90dcbd33c03a0d30a91f227b0e3f341c249dcdef2b009065447e95579e561fee7f4b SHA512 dec2a0eb2dbc692a7e45a2f0df3711057fdc50e7284985d234ed68b3af01372faaa532d070736a005eb49191d55927dc949e9297a6a471b89cf085ef38b56910
+DIST httpx-socks-0.9.2.gh.tar.gz 15445 BLAKE2B 273380fc722780d090039aa74dd646ca3cd5dbc18d5ab3a030847fef0ad515f4ad171289d9cc125d1e8218b8e81a73c1b192caa2708238ed7ac288d3b2419c41 SHA512 41816f9dfa998b8a7e99ddc68d9e3473184fa44ecb08950234759dd9765496e92309852474d8688e392f6a25c4fcbeb7d6358b07bc574c68fd423e05bd052990
diff --git a/dev-python/httpx-socks/httpx-socks-0.9.2.ebuild b/dev-python/httpx-socks/httpx-socks-0.9.2.ebuild
new file mode 100644
index 000000000000..fcd45387461b
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/async-timeout-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hypercorn-0.14.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+
+ distutils-r1_src_prepare
+}