summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-28 03:59:50 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-28 04:00:16 +0000
commit6b68d1fc70bb3e1ba232061c5b02763147a501b4 (patch)
treec898fc499f9cea69bb3d2a940d6167d5c1b95971 /dev-python/fastparquet
parentdev-python/pytables: version bump (diff)
downloadgentoo-6b68d1fc70bb3e1ba232061c5b02763147a501b4.tar.gz
gentoo-6b68d1fc70bb3e1ba232061c5b02763147a501b4.tar.bz2
gentoo-6b68d1fc70bb3e1ba232061c5b02763147a501b4.zip
dev-python/fastparquet: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/fastparquet')
-rw-r--r--dev-python/fastparquet/Manifest1
-rw-r--r--dev-python/fastparquet/fastparquet-0.1.0.ebuild30
-rw-r--r--dev-python/fastparquet/metadata.xml20
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/fastparquet/Manifest b/dev-python/fastparquet/Manifest
new file mode 100644
index 000000000000..844787fdd176
--- /dev/null
+++ b/dev-python/fastparquet/Manifest
@@ -0,0 +1 @@
+DIST fastparquet-0.1.0.tar.gz 118108 SHA256 dad60f61596b0118b50c727d8abd10115ec5e172ca5cb14211a3d6dfe1075c6b SHA512 9aa61f998cd95e4242635ef729c29fa5c66834bdd501fe7d104317a767c5eebc6a1d1aecbd669a39c855f5f2d1650af153b77f12c0120e6e5d13cb8f78e4cba0 WHIRLPOOL c4bc25df8ca0964f6df19840fd7f8c6aab4a6beb2ef8a3d714291121e73a15d3e005cf4534832782eba64a30ba29c63b92d6862a06c7e1db50910d695bbe8a0d
diff --git a/dev-python/fastparquet/fastparquet-0.1.0.ebuild b/dev-python/fastparquet/fastparquet-0.1.0.ebuild
new file mode 100644
index 000000000000..0f06496d4b59
--- /dev/null
+++ b/dev-python/fastparquet/fastparquet-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the parquet columnar file format"
+HOMEPAGE="https://github.com/dask/fastparquet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/snappy[${PYTHON_USEDEP}]
+ dev-python/thriftpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/fastparquet/metadata.xml b/dev-python/fastparquet/metadata.xml
new file mode 100644
index 000000000000..e579ca0f59f7
--- /dev/null
+++ b/dev-python/fastparquet/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ fastparquet is a python implementation of the parquet format,
+ aiming integrate into python-based big data work-flows. Not all
+ parts of the parquet-format have been implemented yet or tested
+ e.g. see the Todos linked below. With that said, fastparquet is
+ capable of reading all the data files from the
+ parquet-compatability project.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">fastparquet</remote-id>
+ <remote-id type="github">dask/fastparquet</remote-id>
+ </upstream>
+</pkgmetadata>