summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 23:39:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 00:20:58 +0100
commitef8c46905054ab03a56d25fc54328a7a3dcaac77 (patch)
treefd28052811e7b624b5c3bd5d1d09b49125822cbe /dev-python/entrypoints
parentapp-admin/awscli: Bump to 1.22.47 (diff)
downloadgentoo-ef8c46905054ab03a56d25fc54328a7a3dcaac77.tar.gz
gentoo-ef8c46905054ab03a56d25fc54328a7a3dcaac77.tar.bz2
gentoo-ef8c46905054ab03a56d25fc54328a7a3dcaac77.zip
dev-python/entrypoints: Bump to 0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/entrypoints')
-rw-r--r--dev-python/entrypoints/Manifest1
-rw-r--r--dev-python/entrypoints/entrypoints-0.4.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/entrypoints/Manifest b/dev-python/entrypoints/Manifest
index 94566c081650..6b344114f99b 100644
--- a/dev-python/entrypoints/Manifest
+++ b/dev-python/entrypoints/Manifest
@@ -1 +1,2 @@
DIST entrypoints-0.3.tar.gz 12315 BLAKE2B f548d98eeb9dcf5760b26f66e5dec0849c9a9027cd68447c07a585e7b80f79a7c66712d0dd270b6960db167d26f9cf0c9c221edd21f2692c2221d36e952ede65 SHA512 aa1274362d3a4b00266103319ca51aa266605b4999c89a9d0673eb61bfae9e646cb0ec6b86c95544493f6fe048385a2c7641d64adca8f45815546fb1e663c858
+DIST entrypoints-0.4.tar.gz 13974 BLAKE2B 95bfe3deeee183f000722be63114e7eafe12ce9994e3ad02fccde7ee8dca3d10cc491e438bc9330fe9e16dbe1664d7a9fd9ef5712ebca989e3304e1dee7a55ce SHA512 874858c240199b9a209e00bde609b33335d199d21a959e51bb875240e2a35ada036380097218e9cd50d5d1dbf9de52638a069cb605ea8e8952db4a5afa3ffd42
diff --git a/dev-python/entrypoints/entrypoints-0.4.ebuild b/dev-python/entrypoints/entrypoints-0.4.ebuild
new file mode 100644
index 000000000000..4a8c9debb7b8
--- /dev/null
+++ b/dev-python/entrypoints/entrypoints-0.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest