summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 08:47:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 09:02:01 +0100
commitacae0a7d016117a206ae6e37e955b71354b21136 (patch)
tree75aaa85f4db6d49949a67669c4dca8775d95c28f /dev-python/elementpath
parentdev-python/zeroconf: Bump to 0.29.0 (diff)
downloadgentoo-acae0a7d016117a206ae6e37e955b71354b21136.tar.gz
gentoo-acae0a7d016117a206ae6e37e955b71354b21136.tar.bz2
gentoo-acae0a7d016117a206ae6e37e955b71354b21136.zip
dev-python/elementpath: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.2.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 83b575dbb341..f180862956dd 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-2.1.4.tar.gz 208691 BLAKE2B 8317c8fa90d7feaff76357c19ed8373644d60985b1d53a1e0a702e26bf80887523a0f1dcf601800ac1618e8f681b3898b5d56fb4edbbffaacbb4a0efe58f67b1 SHA512 d965bd58254e601000da5be309ab18d3f5964cbc1224092e5e38b4523eb3ac2f7ae6e71fa6c3698b40b13484ed1d07bf93c80d45a9b3ad04f69f63bd18a42975
DIST elementpath-2.2.0.gh.tar.gz 222412 BLAKE2B ac05a3ef816713377ec304962732c60f587972e903541748f0f4958aab0456da9aafbccf66d981b852a98d63b37224499af89125e34dae3fec6094f793f823b3 SHA512 db9950fc1d02d3207db73ad0066d681a8e3b293817e2b4fe0c133eff9e8d822f72d2fca4cd631802765d3ee82c2cae69beeae1332b427adac90bca61978d47a9
+DIST elementpath-2.2.1.gh.tar.gz 228166 BLAKE2B 0fb0f338a28d155056bd551dc00e634a00a820945e8147ac8a1eb4811aca9e25c563e9011f1a0de9d2aad5761322fb8d9167b64cc5653bbc4012d0631c81fb05 SHA512 eadeb7fbdaa5470c39a59c8f02047aa8f8e76bfa03087bf2a3206f3fad57ae78da82ccee1de5e6c13207c9e22ca5a45de4c1b4b42c62f8141c8f2bacece02ebf
diff --git a/dev-python/elementpath/elementpath-2.2.1.ebuild b/dev-python/elementpath/elementpath-2.2.1.ebuild
new file mode 100644
index 000000000000..3beb456d1bf3
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest