summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-06-07 09:13:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-06-07 09:13:06 -0500
commit0f0ccd647e91c639efffba1981fa66029b8fb44e (patch)
tree8d43f86fd6ac35a599f017adae94cfd81c8fbf73 /dev-python/dogpile-cache/dogpile-cache-0.6.1.ebuild
parentdev-python/dexml-0.5.1-r0: add ~alpha keyword (diff)
downloadgentoo-0f0ccd647e91c639efffba1981fa66029b8fb44e.tar.gz
gentoo-0f0ccd647e91c639efffba1981fa66029b8fb44e.tar.bz2
gentoo-0f0ccd647e91c639efffba1981fa66029b8fb44e.zip
dev-python/dogpile-cache: bup for bug 585246
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/dogpile-cache/dogpile-cache-0.6.1.ebuild')
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.6.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.6.1.ebuild
new file mode 100644
index 000000000000..78c103a5df65
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}] )"
+
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ # crikey. testsuite written for py3, 5 tests fail under py2.7
+ if [[ "${EPYTHON}" != "python2.7" ]]; then
+ nosetests || die "test failed under ${EPYTHON}"
+ else
+ einfo "testsuite restricted for python2.7"
+ fi
+}