summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-04 14:43:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-04 15:52:37 +0100
commitf85285d5cea3af368898523f11e343f9600e7f1f (patch)
tree195eb85362e0c9f19690b184df7285d8ca4c668b /dev-python/django
parentsys-apps/ripgrep: Remove old (diff)
downloadgentoo-f85285d5cea3af368898523f11e343f9600e7f1f.tar.gz
gentoo-f85285d5cea3af368898523f11e343f9600e7f1f.tar.bz2
gentoo-f85285d5cea3af368898523f11e343f9600e7f1f.zip
dev-python/django: Bump to 5.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest2
-rw-r--r--dev-python/django/django-5.0.3.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index d24e799732c0..d97989d7f3c0 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -4,5 +4,7 @@ DIST Django-4.2.10.checksum.txt 2583 BLAKE2B 5529d8d83fb2ed7ca644ab929809f13ac59
DIST Django-4.2.10.tar.gz 10425081 BLAKE2B ad014b3592d8f5d13d02aa91a029c8cdf85a9e0d3e1b1d3234c833523668059622077eda2fda6cabfd824cf6610b19ca3dc2ceb76c480bde6e97b946812ee162 SHA512 af8c4d596c6ede8a5da9ae0f435ca5c2c17f38b0ff3f31f058e36df695c767813b48f7260bbb8d8a261ef36f836fe1abffc563de185af51080dae1cf3f037f69
DIST Django-5.0.2.checksum.txt 2573 BLAKE2B 705a85beaa4e277fe689d10784f10808b4a06cbb1af7d2417e812d78669256b53d5a2c7678997e96eeb0942c4b31c008628255bb8819e43cbae790b899daa04e SHA512 b37745d0905a2af5793e98c2e00d644f845bcbd236253165cf223b9c748a3f95e6d755d258706769d31fd1009f0815fe1708f6bdb9074343797bb906851ade1a
DIST Django-5.0.2.tar.gz 10619702 BLAKE2B 82608309047fc28f0c3cff15ecfa921b95bae7e2045a75da06e6db4acd74a7508a545ef9419d7b59861832feb6849112d76b49bd87740b797508cfdbaeaf23f6 SHA512 a9270eafb0e270222740ae94b2f866eddaab296768253f0d84c78760a2ac442e0f648af55f74b9b07082f4ccc4eeb91c4facdfdc32ec770936015524fcf4838f
+DIST Django-5.0.3.checksum.txt 2550 BLAKE2B d69fe42e77a1163509f570488b5744571b314b4f24aa0b2f3727ad26ccc53cdc4e16a4b53f21d7e31b0e120462b68397cb31cceded5f4f2d4f0fc9f7afd0f1ee SHA512 abf04cf4fb43f51a8ecef8924e000680184cbb39a9a1a80b679dd1b5cd1e8a90870bc9749b84a6ada79c76cf9c8adb7f870ac0c7ebad68330e8731acdaf3ff22
+DIST Django-5.0.3.tar.gz 10620661 BLAKE2B eaf2f04abf73ad36f7e7825d3655319fbab2268bf5da67ad112e2662f5f5c1bab16d485c75c681ec7e203c111b9676dab2f3552e599a5592a90981e6f7cc75eb SHA512 ed1899007898fc1f6c0889b28fc94016aa9cd2a3556f486bf77efc4310d04896c73bcef93fb4c9162ce884da01c557f6343a20da15a7d6cf2193fd9e88e0dadb
DIST django-4.2.8-pypy3.patch.xz 5900 BLAKE2B b7dc5c5fc162817a218ee6d025ed8a65559b80e4506e49ac393428c26e2621f9e7c5010b36f2412dea8194a9f1086ab21f97286eabd696c6a786285eb07393cf SHA512 f953b5adbd1364f1d84dde55087ccb493256b1327701275fd2fe99f3cd41751d18e002b6e21afc96892e1671428a6b8f3c2e4b88252c3c278f1a79e286bb73e3
DIST django-5.0-pypy3.patch.xz 6124 BLAKE2B 7eba7cc70b30743cf4e186a2c5b0f27c13f49114a7a80bcaa2b25fdd7a959583c115a302c9bc6da97c32f6401cf8f3616818ba759190d317c5b033a0f0088766 SHA512 c550e2b2c1243d13cd1f4908f4b6df606355d1491e3bf72042e4b4777a4474306ff0f67b1c2eb4ab4d137cc85bde52dcdbd54bec245d2ba2e092545be8a2993b
diff --git a/dev-python/django/django-5.0.3.ebuild b/dev-python/django/django-5.0.3.ebuild
new file mode 100644
index 000000000000..1ff45ba52cdf
--- /dev/null
+++ b/dev-python/django/django-5.0.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 multiprocessing optfeature verify-sig
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="
+ https://www.djangoproject.com/
+ https://github.com/django/django/
+ https://pypi.org/project/Django/
+"
+SRC_URI="
+ https://media.djangoproject.com/releases/$(ver_cut 1-2)/${P^}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/python/django-5.0-pypy3.patch.xz
+ verify-sig? ( https://media.djangoproject.com/pgp/${P^}.checksum.txt )
+"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ >=dev-python/docutils-0.19[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/selenium-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/tblib-1.5.0[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ )
+ verify-sig? ( >=sec-keys/openpgp-keys-django-20230606 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/django-4.0-bashcomp.patch
+ "${WORKDIR}"/django-5.0-pypy3.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/django.asc
+
+src_unpack() {
+ if use verify-sig; then
+ cd "${DISTDIR}" || die
+ verify-sig_verify_signed_checksums \
+ "${P^}.checksum.txt" sha256 "${P^}.tar.gz"
+ cd "${WORKDIR}" || die
+ fi
+
+ default
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite \
+ -v2 --parallel="${EPYTEST_JOBS:-$(makeopts_jobs)}" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature_header "Additional Backend support can be enabled via:"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:0
+ optfeature_header
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+}