summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-18 08:22:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-18 08:27:27 +0100
commit2f2edafbb33ed972d5dd5b0259c19b120c6296eb (patch)
tree34758231aad88a0f2330605e7b903df95fe6e79d /dev-python/django-js-asset
parentdev-python/croniter: Bump to 6.0.0 (diff)
downloadgentoo-2f2edafbb33ed972d5dd5b0259c19b120c6296eb.tar.gz
gentoo-2f2edafbb33ed972d5dd5b0259c19b120c6296eb.tar.bz2
gentoo-2f2edafbb33ed972d5dd5b0259c19b120c6296eb.zip
dev-python/django-js-asset: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-js-asset')
-rw-r--r--dev-python/django-js-asset/Manifest1
-rw-r--r--dev-python/django-js-asset/django-js-asset-3.0.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-js-asset/Manifest b/dev-python/django-js-asset/Manifest
index 2296ee76e2a1..e23f8e7120ba 100644
--- a/dev-python/django-js-asset/Manifest
+++ b/dev-python/django-js-asset/Manifest
@@ -1 +1,2 @@
DIST django_js_asset-2.2.0.tar.gz 7904 BLAKE2B 2200ffec739325e01070c53247eb613162bbb09447ea370d3c74bd721c0431cac78e188ac826b6292281b48adfff6789faafdc5c606121262b11c90aeb1900b3 SHA512 23a415fcbc76b9885a1b2831ec87ba64e79019b5595e3865c283c4e558e4cd986b5ab39f25e07308575320684dcc449e1d2029b8f145955f448a9f70bae34951
+DIST django_js_asset-3.0.1.tar.gz 7701 BLAKE2B c504f193b904c8ee3e528ccb69a71629c8a1e392e8e62f05cc1b19f9876d0b7e71de287c218ce5677a3a08d1f32064fc152a954e880403f223e45239698b4489 SHA512 db41a938338696a2dfc3fea6843598a99714c927358c31dfadac41cac743b8f98f7b38e00169496cd2ff54b6d1496bb644c1ccf47c632de767d2964318c9778d
diff --git a/dev-python/django-js-asset/django-js-asset-3.0.1.ebuild b/dev-python/django-js-asset/django-js-asset-3.0.1.ebuild
new file mode 100644
index 000000000000..48c366bb6060
--- /dev/null
+++ b/dev-python/django-js-asset/django-js-asset-3.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Script tag with additional attributes for django.forms.Media"
+HOMEPAGE="
+ https://github.com/matthiask/django-js-asset/
+ https://pypi.org/project/django-js-asset/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ cd tests || die
+ local -x DJANGO_SETTINGS_MODULE=testapp.settings
+ "${EPYTHON}" manage.py test -v 2 || die "Tests failed with ${EPYTHON}"
+}