summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-24 06:02:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-24 07:14:02 +0200
commit49788df505b4cc6e4227860328d5349b9c53b7d8 (patch)
treee186a1a8020d662fe0ea2cffecbe7670791a6b70 /dev-python/denonavr
parentdev-python/zipp: Bump to 3.10.0 (diff)
downloadgentoo-49788df505b4cc6e4227860328d5349b9c53b7d8.tar.gz
gentoo-49788df505b4cc6e4227860328d5349b9c53b7d8.tar.bz2
gentoo-49788df505b4cc6e4227860328d5349b9c53b7d8.zip
dev-python/denonavr: Bump to 0.10.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.10.12.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index acf4bfd30cae..f7a0fb5c80b7 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1 +1,2 @@
DIST denonavr-0.10.11.tar.gz 157622 BLAKE2B aa311eff51dbba857f529aee1a1931b3456b7c42f4710d21aff0eb6cf21718d639795d8099e8b0ad297787ba887746b265f922c19afe692cc3317291023a2df3 SHA512 19a10196019067605a2565be4ee0dc56116d6f706ca97c6754e6dc63cccc8870ee657736fd17f1959753c1c24c878e0d7a721c33212e6753dc12b5fc7dae34e0
+DIST denonavr-0.10.12.tar.gz 167623 BLAKE2B b0d12782e21cf08ba72e069e4952d2c531669de7f357af34f8aa3254cb67c80b75989f67a37281420e7dbb7929082a92327ebf1bb744539e9d2396117ff54714 SHA512 791205d4b367f05388a262935c3e24086cf1603eafc65881fa31e323e9c16c4ac6fd9f09672586fffc63a7a306556183732d71820f05e7c6c66cf17cb33af9c4
diff --git a/dev-python/denonavr/denonavr-0.10.12.ebuild b/dev-python/denonavr/denonavr-0.10.12.ebuild
new file mode 100644
index 000000000000..7f99008f42e8
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.10.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest