summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-01 18:52:31 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-01 18:53:24 +0200
commita08c29ca79f0f1d39af0ea7b23b29e22c4a5eab7 (patch)
treebd951fe5e3eb45b09a12e2b8fcf0d98873ae19d2 /dev-python/crispy-bootstrap4
parentgames-strategy/freeciv: drop obsolete nmap[system-lua] mask (diff)
downloadgentoo-a08c29ca79f0f1d39af0ea7b23b29e22c4a5eab7.tar.gz
gentoo-a08c29ca79f0f1d39af0ea7b23b29e22c4a5eab7.tar.bz2
gentoo-a08c29ca79f0f1d39af0ea7b23b29e22c4a5eab7.zip
dev-python/crispy-bootstrap4: new package, add 2022.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/crispy-bootstrap4')
-rw-r--r--dev-python/crispy-bootstrap4/Manifest1
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild25
-rw-r--r--dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch17
-rw-r--r--dev-python/crispy-bootstrap4/metadata.xml12
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap4/Manifest b/dev-python/crispy-bootstrap4/Manifest
new file mode 100644
index 000000000000..5c4459a71470
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/Manifest
@@ -0,0 +1 @@
+DIST crispy-bootstrap4-2022.1.gh.tar.gz 30814 BLAKE2B 573847b614b5f6cf71fea6ed6831eeef48ac01b2c2db07653d600b5b0829209188d235a143585ed4fabb663264aff3b5f7a416d99d12a8e268d4c62edaf3db84 SHA512 7f1e5443229274de2aaf28bd63507bbe5dff7923f27509801ea9de9246fa393bfc4563a4aa6d586a1e642b87bb7dddcb3ad3403653912c0197f8638141c42229
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
new file mode 100644
index 000000000000..c4ec3ed11b1c
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap3 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://pypi.org/project/crispy-bootstrap3/
+"
+SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/django-crispy-forms[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
diff --git a/dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch b/dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch
new file mode 100644
index 000000000000..1432235e3b56
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/files/crispy-bootstrap4-2022.1-test.patch
@@ -0,0 +1,17 @@
+--- a/tests/test_form_helper.py 2023-04-01 18:48:25.847263389 +0200
++++ b/tests/test_form_helper.py 2023-04-01 18:48:38.817091994 +0200
+@@ -633,14 +633,6 @@
+ assert '<div class="form-group row">' not in html
+
+
+-def test_template_pack_bs4():
+- form = SampleForm()
+- form.helper = FormHelper()
+- form.helper.template_pack = "bootstrap3"
+- html = render_crispy_form(form)
+- assert "controls" in html # controls is bootstrap3 only
+-
+-
+ def test_passthrough_context():
+ """
+ Test to ensure that context is passed through implicitly from outside of
diff --git a/dev-python/crispy-bootstrap4/metadata.xml b/dev-python/crispy-bootstrap4/metadata.xml
new file mode 100644
index 000000000000..d64ea15e9cf2
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">crispy-bootstrap4</remote-id>
+ <remote-id type="github">django-crispy-forms/crispy-bootstrap4</remote-id>
+ </upstream>
+</pkgmetadata>