summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 10:09:29 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 10:18:12 +0100
commit229c35ef94b7213ebd20ecb8ba3f0ffc63069461 (patch)
treef6efb2c607a6a878acbc76622a156fd082f4e8cc /dev-python/capturer/capturer-3.0-r1.ebuild
parentdev-python/mypy: drop 0.971, 0.981, 0.982 (diff)
downloadgentoo-229c35ef94b7213ebd20ecb8ba3f0ffc63069461.tar.gz
gentoo-229c35ef94b7213ebd20ecb8ba3f0ffc63069461.tar.bz2
gentoo-229c35ef94b7213ebd20ecb8ba3f0ffc63069461.zip
dev-python/capturer: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/capturer/capturer-3.0-r1.ebuild')
-rw-r--r--dev-python/capturer/capturer-3.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/capturer/capturer-3.0-r1.ebuild b/dev-python/capturer/capturer-3.0-r1.ebuild
new file mode 100644
index 000000000000..211c82b9d04f
--- /dev/null
+++ b/dev-python/capturer/capturer-3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.io/en/latest/
+ https://pypi.org/project/capturer/
+ https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ epytest ${PN}/tests.py
+}