summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-15 22:01:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-15 22:26:06 +0200
commit094fb16a51d442ac0285e19360218757927be029 (patch)
tree8a470ef47e311c4f81d4d029eb47a2b4c493a3d1 /dev-python/breathe
parentx11-misc/synergy: Bump to 1.14.1.32 (diff)
downloadgentoo-094fb16a51d442ac0285e19360218757927be029.tar.gz
gentoo-094fb16a51d442ac0285e19360218757927be029.tar.bz2
gentoo-094fb16a51d442ac0285e19360218757927be029.zip
dev-python/breathe: Bump to 4.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/breathe')
-rw-r--r--dev-python/breathe/Manifest1
-rw-r--r--dev-python/breathe/breathe-4.31.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/breathe/Manifest b/dev-python/breathe/Manifest
index 45a78921e9e0..2f6e107b164b 100644
--- a/dev-python/breathe/Manifest
+++ b/dev-python/breathe/Manifest
@@ -1 +1,2 @@
DIST breathe-4.30.0.tar.gz 190892 BLAKE2B 19723ed2f979eedcab73a9920c37cf6d3f6e02ff08703d601cc38fe55ecbac28b8ef8d319205723fce75b5e679a75fbd8e712dc134358e1ba6c23dfcb999a472 SHA512 fa09ee687a8e67fa480865a0d33affd9aa0ab48b0cb5b685731ec393045d8c9e1ae0622a1315f805449d712e99e6982ed229bb79314c69f69da0c705d075f7f9
+DIST breathe-4.31.0.tar.gz 193629 BLAKE2B d883f5d8ec339e3bb3db7382e17b27445f4ac05039aaa6ecc29fb38db51e95483c559e78cf642e70bea975c42b1ef2ed48d8804fd9557f7693139b7f5639dc3d SHA512 f6fd7db50ca68cad64d150fcb76227deb282c08109c38b343749f8ce9ee607ccddf767e3020328a61a7570e7a0c1159607148b773bc0b695e87d6b17a6068eac
diff --git a/dev-python/breathe/breathe-4.31.0.ebuild b/dev-python/breathe/breathe-4.31.0.ebuild
new file mode 100644
index 000000000000..b0fbc7e01e85
--- /dev/null
+++ b/dev-python/breathe/breathe-4.31.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Doxygen renderer"
+HOMEPAGE="
+ https://breathe.readthedocs.io/en/latest/
+ https://github.com/michaeljones/breathe/"
+SRC_URI="https://github.com/michaeljones/breathe/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-doc/doxygen
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.0.0[${PYTHON_USEDEP}]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+"
+
+distutils_enable_tests pytest