summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 19:47:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 20:02:04 +0100
commited3c1682dfabcf46fe9f082089950e2fa38b6fa3 (patch)
tree8078b25b59d101c7b7f4b719c5a2df54e71be098 /dev-python/bottle
parentdev-python/google-api-python-client: Bump to 2.79.0 (diff)
downloadgentoo-ed3c1682dfabcf46fe9f082089950e2fa38b6fa3.tar.gz
gentoo-ed3c1682dfabcf46fe9f082089950e2fa38b6fa3.tar.bz2
gentoo-ed3c1682dfabcf46fe9f082089950e2fa38b6fa3.zip
dev-python/bottle: Bump to 0.12.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest1
-rw-r--r--dev-python/bottle/bottle-0.12.24.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index a4d5566e86b3..92e794c0a802 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1 +1,2 @@
DIST bottle-0.12.23.tar.gz 73965 BLAKE2B ccd3dc3aad5c4c8b6899f55f03550cf9178e51788c27ece9808e1cff92693cc09dab145be16f814d29dae02ce53374a0470b2c4b032bc66a0ec2b1a11ec5ca44 SHA512 0550aa95680dd79d9c63c5de854845377183c86015893d9ee4e67126eca201582ef79d40ff0d1cbe79fe8a250118a775c63102475e337e18cfc1a65afe18f62a
+DIST bottle-0.12.24.tar.gz 74146 BLAKE2B a6bb638a0cba4d5fadbcb3a1a303b66a04f3c4df84e34b87d4a9bb22178de943123403d2851bd28504cf9d91380af95dd108e3b84825a93a6345cbe39fec0c33 SHA512 a3bc4bdc1376aef6c7b5784de18bfaac83e2c0c279fb2c3c3a8322871c68516e858b8c82cfff9291d41a66b906c13099c9d1037184bc48ff6f4ef0783b048f9b
diff --git a/dev-python/bottle/bottle-0.12.24.ebuild b/dev-python/bottle/bottle-0.12.24.ebuild
new file mode 100644
index 000000000000..e7fcb7168349
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e '/scripts/d' -i setup.py || die
+
+ # Remove test file requiring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}