summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-07-25 16:02:32 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-07-25 16:25:31 -0700
commitbf9595a14fcc7cc897f63fef7199cf20133b8094 (patch)
tree30963906ed3a6bf762d8597ff4e655d1afb8882c /dev-python/boto3
parentdev-python/botocore: Version bump (diff)
downloadgentoo-bf9595a14fcc7cc897f63fef7199cf20133b8094.tar.gz
gentoo-bf9595a14fcc7cc897f63fef7199cf20133b8094.tar.bz2
gentoo-bf9595a14fcc7cc897f63fef7199cf20133b8094.zip
dev-python/boto3: Version bump
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.28.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index ab896bf7aff4..86a7f65aab56 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.13.26.tar.gz 296782 BLAKE2B 117bb18679fe3ae8c4feee1a5fb2d1df1923764
DIST boto3-1.14.20.tar.gz 299325 BLAKE2B e1105a2ba55d59dc4d9a73f40e3bc34c05ceda906963d162eeeac8542d234a85b01e2ed485069269e923e2697b33c3f8e77af474716d8b2fa2a2f3ecf4093168 SHA512 d8f281d41386754c3720eeade23bb7b3c2b74176b5e0a763c5f355ed44e52f651d76a10dcc947142f0438be7c983bfc26ec8d31a1b341f55149188e6e7d6d1d8
DIST boto3-1.14.23.tar.gz 299581 BLAKE2B 57cbb3fbd9a84f334b5874ca96490cb0269bb79f3fd2b50d4c51efcfadaa41b2e11853266ba12544b77999fa85fefb0bdf84d924667c4092b3deb72f41e33a21 SHA512 263b2abf3c220d3fb3d7acf4cd87266c11d3dcd5d7ffcafb0aab128b1e324d6f99c44de8abfb621b153b5fc51b9823b6b79ea5c529f6c59c548c900015bcdb5e
DIST boto3-1.14.27.tar.gz 299871 BLAKE2B b0bca67cc43af0eb6d823ddf256e219c1137793a211c9f02fcbcba364887882496c98d1463b899c68e65127b2ddb3a4781f93237365a2fc539ba07b43714479e SHA512 3576d0ebe1167cf6ce9decd1efd9c55c5e06074303da38bee236c8f0bf1fb0ae459e88ae5719590a0e7aa02936277e5c08a35e5bf08249f50716b6147f7872a4
+DIST boto3-1.14.28.tar.gz 299959 BLAKE2B 7318fd60ccd46e12f38eb14aeecfb59fd951ed9749990f2b7bfc991b2a5077d2afe93a37b28f833ec232e85cd85a454887672be3b6b72b37e696677c45c9287c SHA512 e83695d00f2d08ad129be24f2a387fcd7181f727bd4c64df1d3d8a14aff280388262032b60f7a01829ffcaeb639eeebc9e1e85a786f3228e1d28ed4d15166ca7
diff --git a/dev-python/boto3/boto3-1.14.28.ebuild b/dev-python/boto3/boto3-1.14.28.ebuild
new file mode 100644
index 000000000000..d996a7288df9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.28.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-1.15.48[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_sphinx docs \
+ 'dev-python/guzzle_sphinx_theme'
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}