summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-11 15:08:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-11 15:31:47 +0100
commit2c4b039601929b150ce40a121a9f4e7a5abb627a (patch)
tree6dc462ea76ad7301e0f507af85e95f266ff69346 /dev-python/aws-sam-translator
parentdev-python/django-otp: Bump to 1.1.4 (diff)
downloadgentoo-2c4b039601929b150ce40a121a9f4e7a5abb627a.tar.gz
gentoo-2c4b039601929b150ce40a121a9f4e7a5abb627a.tar.bz2
gentoo-2c4b039601929b150ce40a121a9f4e7a5abb627a.zip
dev-python/aws-sam-translator: Bump to 1.54.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aws-sam-translator')
-rw-r--r--dev-python/aws-sam-translator/Manifest1
-rw-r--r--dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/aws-sam-translator/Manifest b/dev-python/aws-sam-translator/Manifest
index 1ddd70e919f1..17bc20154ff6 100644
--- a/dev-python/aws-sam-translator/Manifest
+++ b/dev-python/aws-sam-translator/Manifest
@@ -1 +1,2 @@
DIST aws-sam-translator-1.53.0.gh.tar.gz 1158682 BLAKE2B 4bc8430936a1b180dc04637e540ecad7eb82cd7a5da5254f2b823075878a03ad3e63422c183b365b0dad927bcdf063b8ab40984ab23abe1d91d8bc3c411aa2f1 SHA512 292259bf8d4002b72be51db0358673eee61fe368be5db15e7faff195baae8fa194bef882fd0f5a9b5c46379fe5f9593d101a212121da8d0636aca709dd087f05
+DIST aws-sam-translator-1.54.0.gh.tar.gz 1004760 BLAKE2B acb875f6f25c43d605dc1a2ee38bde66eacc8de85aaa8c3231ded77a9252e1d722a82724e2d8bb8016e1d8cb7bd188c7dcb76e50ac79af20109713160b90a891 SHA512 a8dbf74e983eab124cfab7627f64fb013a59340b77820a96c5654503956370aeca51a676508b688d2f1c96c1fb9586c7711f03af5ca68f680edbb19516007f4f
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild
new file mode 100644
index 000000000000..307deef634c3
--- /dev/null
+++ b/dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="
+ https://github.com/aws/serverless-application-model/
+ https://pypi.org/project/aws-sam-translator/
+"
+SRC_URI="
+ https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/serverless-application-model-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/boto3-2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.19.5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/validator/test_validator_api.py::TestValidatorApi::test_errors_13_error_definitionuri
+ tests/unit/test_region_configuration.py::TestRegionConfiguration::test_is_service_supported_positive_4_ec2
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_success_one_app
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_throttling_doesnt_stop_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sleep_between_sar_checks
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_unexpected_sar_error_stops_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_and_on_after_transform_template::test_time_limit_exceeds_between_combined_sar_calls
+)
+
+python_prepare_all() {
+ # remove pytest-cov dependency
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ # deps are installed by ebuild, don't try to reinstall them via pip
+ truncate --size=0 requirements/*.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}